MyMDb-CE 1.X.X (Fragen / Bugs / Wünsche)

Erstellt von tbengel, 24 Dezember 2018, 09:22:15

Vorheriges Thema - Nächstes Thema

0 Mitglieder und 1 Gast schauen sich dieses Thema an.

hamlet

Noch ein Bug: Das Hinzufügen von Filmen über den OFDb-Link funktioniert nicht.

Beispiel: Das deutsche Drama "Wild", liefert über "Film hinzufügen->Auf OFDb suchen" ungefähr 1000 Treffer.

Also den OFDb-Link (https://ssl.ofdb.de/film/286253,Wild) in das Feld von "OFDb-Link einfügen" eingegeben. Als Ergebnis bekommt man eine Message-Box "Bitte überprüfen Sie die eingegebene URL".

Auch wenn man den Link verkürzt und das Komma und den Titel weglässt erhält man dasselbe Ergebnis.

tbengel

Hallo hamlet,

dies hängt mit dem neuen Url-Aufbau der OFDb zusammen. Kann man vielleicht noch anpassen.
Ich nehme es in die ToDo auf ...

Nehme immer den Link, der in allen deinen Filmen im OFDb-Feld steht, also:

http://www.ofdb.de/view.php?page=film&fid=

und ergänze diesen um die ID aus dem neuen OFDb-Link, also für Wild:

https://ssl.ofdb.de/film/286253,Wild --> http://www.ofdb.de/view.php?page=film&fid=286253

dann klappt es auch mit dem Hinzufügen ;-))

Grüße

tbengel

hamlet

Danke! Den Workaround kenne ich :-). Ist aber natürlich unschön und auch eher was für Spezialisten ;-).

BTW: Was ist denn aus den Plänen geworden, den Code auf Github zu veröffentlichen? Dann würde ich solche Probleme (und auch die Pfad-Probleme unter linux) selbst beheben :-)

tbengel

@hamlet:
ZitatDanke! Den Workaround kenne ich :-). Ist aber natürlich unschön und auch eher was für Spezialisten ;-).

Ist in der nächsten Version gefixt ...

ZitatBTW: Was ist denn aus den Plänen geworden, den Code auf Github zu veröffentlichen? Dann würde ich solche Probleme (und auch die Pfad-Probleme unter linux) selbst beheben :-)

Dies erfährst Du alles in der nächsten Woche (rechtzeitig mit der neuen Test-Version :dodo:)

Grüße

tbengel

Fluorchlor

Hallo,

ich bin auch restlos begeistert, insbesondere wie leicht der Umstieg klappt,
meine Sammlung wird ebenfalls mit Cover angezeigt, leider werden jedoch bei mir weder in der Suche (Windows 10) noch beim Übernehmen eines Filmes die Cover angezeigt,
ich habe alle Rechte, als Administrator gestartet, und sowohl auf meiner alten bestehenden Umgebung als auch ganz neu gestartet mit einer leeren DB.

Habe ich irgend etwas überlesen bisher, ich habe auch die neueste JRE/Java-Umgebung installiert, das hat nichts gebracht.

Vielen Dank für Eure Tipps.

Gruß,

Fluorchlor

tbengel

@Fluorchlor:

Bei @toni1967 lag es daran:

ZitatGelöst. Ich habe ein Update auf die allerneueste JRE (Java 8 - Update 191) gemacht. Jetzt werden die Cover bei der Suche angezeigt.


Also überprüfe mal Deine Version JRE-Version. Wenn alles passt, dann Deine JAVA-Versionen vorher deinstallieren und die aktuelle neu installieren und achte darauf, dass Du die 191er hast.

Grüße

tbengel

Peter

Hallo
Klasse was ihr hier realisiert habt ... ich war schon lange auf der Suche nachdem das Problem mit OFDB auftrat,
MyMDB-CE installiert und alles problemlos aus der alten Verison importiert ... TOP!

Zwei Dinge:
1. Wo kann ich schnell sehen, welche Version (Versionsnummer) die aktuelle ist? Ein extra Thread mit den jeweiligen Updates/Versionshinweise wäre nett.
2. Wenn ich einen Film manuell hinzufüge und OFDB und IMDB frei lasse  (weil es ein eigener ist oder der Film in diesen Datenbanken nicht enthalten ist - gibt's auch) kommt die Meldung
"Ein Film mit derselben OFDB-ID aber unterschiedlichem Titel befindet sich bereits in der Datenbank. Soll dieser trotzdem hinzu gefügt werden?".
Der Film befindet sich aber garantiert nicht in der Datenbank.

Live-Suche wurde ja bereits angesprochen. Auch dies vermisse ich sehr. Hierzu noch ein möglicher zusätzlicher Lösungsanstz: Viellleicht bei den Einstellungen eine Option zur Zwischenschaltung der Detailsuche JA/NEIN einbinden. Wenn dann nicht gewüncht dann gleich zum Suchvorgang übergehen und dieses Zwischenfenster auslassen.

Ansonsten meinen höchsten Respekt für die Leistung der Community.

Peter

tbengel

@Peter:
zu 1) Hierzu immer den ersten Post anschauen, dort werden alle Änderungen vermerkt und auch wenn es eine neue Version gibt (wie schon bald) ..., oder auch im Thread "Ankündigungen zu MyMDb-CE (Community Edition)" (https://www.gemeinschaftsforum.com/forum/index.php/topic,218107.0.html).
zu 2) Wäre nie darauf gekommen, dass jemand dort Filme ohne OFDb-Link einträgt. Wenn ich dies tue, dann erstelle ich immer Pseudo-OFDb-Links
wie z.B. "http://www.ofdb.de/view.php?page=film&fid=9993053";, also Links die es nicht gibt, mir aber die Möglichkeit bieten dennoch eine Eindeutigkeit
zu gewährleisten. In MyMDb 3.6 wurde immer nur anhand des Titels eine Eindeutigkeit überprüft, aber da es immer mehr Titel gibt, die sich gleichen,
habe ich nun in erster Linie den OFDb-Link überprüft, was natürlich nicht klappt, wenn dieser leer ist. Ich nehme dies mal in die ToDo-Liste auf.

Zum Thema Live-Suche: Ich persönlich fand die Live-Suche auch schöner, aber in der Version 3.2.3 gab es diese noch nicht, sondern die Suche wurde über das Suche-Fenster erledigt. Für die Live-Suche muss die eigentliche Suche vom Suche-Fenster entkoppelt werden (auch wenn Du eine "Zwischenschaltung der Detailsuche JA/NEIN" einbaust), was nicht unerhebliche Programmierarbeit erfordert, steht aber bereits in der ToDo.

Grüße

tbengel

tbengel

7 Januar 2019, 12:14:55 #128 Letzte Bearbeitung: 7 Januar 2019, 16:58:02 von tbengel
Hallo,

es gibt heute einige Neuigkeiten zu verkünden.

1. Wir haben in unserem Team endlich einen echten Java-Programmierer, @Hannibal der mich unterstützt (naja, eigentlich hat
er die letzten zwei Wochen die ganze Arbeit alleine gemacht und ich habe mich im wesentlichen auf kleinere Bugs konzentriert :icon_redface:).
Seinen Einstand gibt @Hannibal gleich mit der neuen Version 1.1.0, die soeben an 12 Tester vorab ausgeliefert wurde. In dieser sind nun
endlich zwei der wichtigsten Feature vorhanden, die noch gefehlt haben und ich nicht hinbekommen habe, nämlich:

- Speichern und nächster Film
- Verschieben auf Position

Weiterhin wurde folgendes umgesetzt:

- "Nächster Film ohne speichern"
- neue Medientypen von @birkner
- in der Config editierbare Tonformatliste

und die folgenden Bugs wurden beseitigt:

- Plot- und Kommentar-Spalte wird mit einen Gap von ca. 3 Zeilen angezeigt
- Sonderzeichenfehler: "Fehler beim Entschl\\u00fcsseln der MyMDb-DB"
- Spalte MedienTyp lässt sich in der Breite nicht verändern
- Beim Erstellen von Backups im MyMDb-CE V.0.9.8, ist bei beim Speichernamen die Uhrzeit auf Stunden gekürzt.
- blaues Fenster bleibt stehen mit dem Text "Titel wird gesucht" nach fehlgeschlagener Suchanfrage
- ssl.ofdb-Url bei OFDb-Link-Eingabe umwandeln
- Doppelter-Film-Abfrage bei leerem OFDb-Link

Sobald die Tester Ihr "OK" geben, wird die Version freigegeben. Aber bitte erwartet jetzt nicht, dass es alle 2 Wochen
eine neue Version gibt. Es hat nur gerade gepasst, weil wir beide Urlaub hatten und so die Feiertage "sinnvoll" nutzen
konnten. Ab jetzt wird wieder "normal gearbeitet" und da bleibt dann wesentlich weniger Zeit für das Programmieren.

2. Das altbewährte Tester-Team, wurde um die drei freiwillige Tester:

@DerSteppenwolf1977
@Fluorchlor
@MxO2204

erweitert. Zusätzlich wird aber nun auch @perlian mit testen (müssen  ;)), damit die Linux-Version stabil bleibt. Die Erweiterung
des Teams ist notwendig, damit es bei der großen Zahl von Usern nicht irgendwann eine böse Überraschung gibt.

3. Der Source ist nun komplett in einer Versionsverwaltung (GIT) verfügbar, so dass nun mehrere Programmierer gleichzeitig am
Code arbeiten können. Markus (der Programmierer von MyMDb 3.6) hat uns die Ressourcen dafür zur Verfügung gestellt. Herzlichen
Dank dafür nochmal ... Also wer von sich glaubt, java-technisch ebensolche "Wunderwerke" wie @Hannibal hinzubekommen, kann
sich gerne bei mir melden ...  :respekt:

@hamlet: ... ja auch Dich im Speziellen meine ich :icon_mrgreen:, damit Du das Programm noch Linux-tauglicher mitgestalten kannst ...

Jetzt liegt alles nur noch an den Testern, wann die neue Version ausgerollt wird.

Grüße

tbengel

atze

Hey, habe kürzlich von diesem Projekt erfahren und warte seither gespannt auf die Veröffentlichung des Codes.  In Antwort #123 klang es noch so als ob der Code auf GitHub veröffentlicht wird. Wird das noch gemacht? Wenn ja, unter welcher Lizenz?

tbengel

@atze: Das war so geplant, aber da die Lizenzfrage noch nicht abschließend geklärt und wir Forks, also andere Filmverwaltungs-Programm-Versionen auf Basis des aktuellen Quellcodes, vermeiden wollen, ist das GIT erst einmal privat und nur über einen speziellen Zugang zu erreichen.

Grüße

tbengel

atze

@tbengel: Verstehe.

Da ich jetzt registriert bin, hier ein paar Fragen:

- Wo werden die Datenbanken gespeichert?
- In welchen Format werden die gespeichert?
- Ist es möglich, die Datenbank auf einem Server zu speichern? (Wenn nicht: Was much ich tun, um Zugang zum Sourcecode zu bekommen, damit ich abschätzen kann wie groß der Aufwand wäre um das zu implementieren?)


tbengel

7 Januar 2019, 14:03:25 #132 Letzte Bearbeitung: 7 Januar 2019, 14:27:16 von tbengel
@atze: Ist eine ganz normale HSQLDB also eine "In-Memory-Datenbank", die gespeichert wird in der Datei "data\mymdbce.script", die du ganz normal mit einem Text-Editor (ist eine ganz normale Text-Datei) einlesen und verändern kannst (aber alles auf eigene Gefahr!!!).
--> Habe den Satz gerade nochmal gelesen ... wow 3 x die Wörter "ganz normal" in einem Satz, das ist ja schon fast rekordverdächtig, ich glaube ich brauche eine Tasse Kaffee :andy:

Grundsätzlich kann diese überall hin (also auch auf einen Server) gespeichert werden, wenn der Pfad der DB konfigurierbar ist (was er zur Zeit noch nicht ist). Zu beachten ist dabei natürlich noch, dass auch die Bilder und Cover im Verzeichnis "images", auf dem Server gespeichert werden müssten, um von verschiedenen Orten, auf die DB zugreifen zu können.

Grüße

tbengel

Korv

Vers. 1.10
Das Speichern der Datenbank und wiederherstellen funktioniert unter Win7 64 einwandfrei.
Was mir aufgefallen ist :
Beim hinzufügen eines Films :
Nachdem ich den Speicherort angegeben habe und auf Speichern klicke geht die Maske nicht von alleine weg.
Der Button " Speichern" ist noch invertiert.
Ich schließe die Maske über das kreuz, der Film ist dann gespeichert auch mit dem richtigen Lagerort.


atze

@tbengel: Danke für die Infos.

ZitatGrundsätzlich kann diese überall hin (also auch auf einen Server) gespeichert werden, wenn der Pfad der DB konfigurierbar ist (was er zur Zeit noch nicht ist).

Ist das in Planung? Ich biete gerne meine Unterstützung an.

Old.Obelix

7 Januar 2019, 20:33:26 #135 Letzte Bearbeitung: 9 Januar 2019, 01:15:53 von Old.Obelix
Testbericht MyMDb-CE.V.1.1.0 der Erste!

Das Speichern und wiederherstellen der Datenbank funktioniert unter Win7 64 und 10 Prof einbahnfrei.

Beim Hinzufügen oder bearbeiten eines Films, funktioniert weder speichern sowie speichern & nächster.
Das Fenster Bearbeiten schließt nicht und der jeweilig gedrückte Button bleit als aktiviert angezeigt.

Abbrechen & nächster funktioniert.

Beim Verschieben eines Films auf eine andere Positionsnummer und der Verleihfunktion, tritt das gleiche Problem auf.
Das Fenster Bearbeiten schließt nicht und der jeweilig gedrückte Button bleit als aktiviert angezeigt.

Bei mir ist es noch etwas krasser als bei Korv, ich kann bei mir Version 1.1.0 nur noch über den Taskmanager beenden.

Erstaunlich ist, dass nach einem anschließenden Neustart sämtliche Änderungen, anstandslos übernommen werden.

In der Spaltenansicht, werden die Kommentare zwar jetzt ganz oben angezeigt, aber das gesetzte Komma,
dass in der Version 1.0.0 noch als Zeilenumbruch diente, wird jetzt als Komma angezeigt.
Der Text wird nicht mehr ausgemittelt und ist somit unübersichtlicher.

Komma als Zeilenumbruch und ausmitteln des Texts ist Optisch wesentlich schöner und übersichtlicher. :icon_eek:

Und bitte benennt den ORT im bearbeiten Fenster wieder in Lagerort um wie in der Spaltenansicht
oder macht aus beiden Ablage oder ??? um ein verständliches und einheitliches Erscheinungsbild zu haben.

Ansonsten konnte ich nichts Weiteres feststellen. Sollte noch etwas auffallen, werde ich es euch umgehend wissen lassen.

LG
Old.Obelix

birkner

Linuxmint 18.3 (Ubuntu 16.04):
-Neuanlegen Film ohne Probleme, alle Fenster werden wieder geschlossen.
-Änderungen in config.txt ohne Probleme akzeptiert.
-allgemeines Problem unter Linux (bereits angesprochen): Beim Öffnen eines Fensters muss erst in das Fenster geklickt werden um zu arbeiten oder es wieder zu schließen (damit konnte man aber gut leben).
Besonders aber im Plot-Fenster: Wenn dort mit Rechtsklick und Einfügen ein zusätzlicher Text eingefügt werden soll, wird der bereits vorhandene Text gelöscht. Eine Ergänzung funktioniert nur sauber mit ctrl c und ctlr v. Auch einen Text aus einem Fenster herauszukopieren geht nur über die ctrl-Befehle.
VG birkner

Flämmer

Zitat von: Old.Obelix nach  7 Januar 2019, 20:33:26
Beim Hinzufügen oder bearbeiten eines Films, funktioniert weder speichern sowie speichern & nächster.
Das Fenster Bearbeiten schließt nicht und der jeweilig gedrückte Button bleit als aktiviert angezeigt.

Beim Verschieben eines Films auf eine andere Positionsnummer und der Verleihfunktion, tritt das gleiche Problem auf.
Das Fenster Bearbeiten schließt nicht und der jeweilig gedrückte Button bleit als aktiviert angezeigt.


Hallo zusammen

Habe das gleiche problem.

birkner

-Linuxmint 19.1 (Ubuntu 18.04) gleiche Funktionalität wie Linuxmint 18.3 (Ubuntu 16.04)
-Filterfunktion ok mit Bearbeiten speichern-nächster, abbrechen nächster ok.
-Verschieben auf andere Nummer klappt unter linux
VG birkner

Old.Obelix

7 Januar 2019, 22:53:46 #139 Letzte Bearbeitung: 7 Januar 2019, 23:14:00 von Old.Obelix
Zitat von: birkner nach  7 Januar 2019, 21:50:27
Linuxmint 18.3 (Ubuntu 16.04):

Besonders aber im Plot-Fenster: Wenn dort mit Rechtsklick und Einfügen ein zusätzlicher Text eingefügt werden soll, wird der bereits vorhandene Text gelöscht. Eine Ergänzung funktioniert nur sauber mit ctrl c und ctlr v. Auch einen Text aus einem Fenster herauszukopieren geht nur über die ctrl-Befehle.
VG birkner


Das angesprochene Problem von birkner unter Linux, habe ich unter Windows 7 und 10 Prof ebenfalls festgestellt.
Wenn mit Rechtsklick und Einfügen ein zusätzlicher Text eingefügt werden soll, wird der vorhandene Text gelöscht.
Nur unter Windows betrifft das alle Texteingabefenster, bei denen nur eine Ergänzung mit CTRL v
ohne den vorhandenen Text zu verlieren möglich ist.

Einen Text aus einem Fenster herauskopieren, geht auch wie von birkner beschrieben nur mir CTRL c
und nicht über die rechte Maustaste bei allen Texteingabefenstern.

Unter den Eingabefeldern MyNr, EAN und Label kann man nur mit CTRL v einfügen und CTRL c Text herauskopieren arbeiten.
Ebenso ist es bei dem Texteigabefeld SUCHE.

Das Betritt unteranderem auch die Vollversion MyMDb-CE.V1.0.0

Dann hätte ich noch einen Neujahrswunsch!

Der Lagerort, wurde bereits in der Suchoption eingeführt.
Wenn es machbar ist würde ich mir hier auch noch eine Filteroption als Arbeitserleichterung wünschen,
wenn die Suchfunktion dadurch nicht beeinträchtigt wird.

LG
Old.Obelix

tbengel

Hallo,

ich habe keine Ahnung was ihr anders macht als wir. Sowohl @Hannibal, als auch ich können keine der Fehler mit dem "Speichern" reproduzieren. Ich sitze hier schon seit einer Stunde, bekomme aber keinerlei Fehler, egal was und wie ich Filme neu hinzufüge ...

@Korv:
ZitatBeim hinzufügen eines Films :
Nachdem ich den Speicherort angegeben habe und auf Speichern klicke geht die Maske nicht von alleine weg.
Der Button " Speichern" ist noch invertiert.

Klappt bei uns ohne Probleme, bitte mal genau schildern was Du Schritt für Schritt machst ...

@Old.Obelix & @Flämmer:
ZitatBeim Hinzufügen oder bearbeiten eines Films, funktioniert weder speichern sowie speichern & nächster.
Das Fenster Bearbeiten schließt nicht und der jeweilig gedrückte Button bleit als aktiviert angezeigt.

Auch hier, habe ich keine Ahnung, wie man dies reproduzieren kann. Bei einem Film der neu hinzugefügt wird,
gibt es außerdem die Buttons "speichern & nächster" oder "abbrechen & nächster" gar nicht. Bitte auch hier mal
genau schildern was Du Schritt für Schritt machst ...

Bitte testet diese Sachen auch mit der alten Version 1.0.0, ob es dort auch schon diese nicht reproduzierbaren Fehler
gibt.

Danke und Grüße

tbengel

pudding

8 Januar 2019, 00:45:14 #141 Letzte Bearbeitung: 8 Januar 2019, 00:56:05 von pudding
Hinzufügen und speichern geht bei mir ohne Probleme, nur wenn ich bearbeite und auf speichern gehe dauert es immer 15 Sekunden bis das Fenster zu geht, auch wenn ich nichts ändere , bei Speichern / nächster ist das selbe, nur bei abbrechen und nächster geht es sofort .


Alles auf Win 7 pro


Noch mal schnell die 1.0.0  genommen ,  da is alles gut,  dann die neue wieder drüber und Fehler wieder da

tbengel

pudding:
Zitat... nur wenn ich bearbeite und auf speichern gehe dauert es immer 15 Sekunden bis das Fenster zu geht, auch wenn ich nichts ändere

Hast du das gleiche Problem auch schon bei der 1.0.0?

Grüße

tbengel

pudding

Zitat von: tbengel nach  8 Januar 2019, 00:51:27
pudding:
Zitat... nur wenn ich bearbeite und auf speichern gehe dauert es immer 15 Sekunden bis das Fenster zu geht, auch wenn ich nichts ändere

Hast du das gleiche Problem auch schon bei der 1.0.0?

Grüße

tbengel


Nein . hab grad die 1.0.0 drüber , da ist das nicht

pudding

8 Januar 2019, 01:07:42 #144 Letzte Bearbeitung: 8 Januar 2019, 01:18:09 von pudding
Es liegt wohl an der Größe der Datenbank  , wenn ich bei Film Nr 1 auf Speichern und Weiter gehe geht es sofort ...
Bei Film 100 dauert es 5 Sekunden ...
Bei Film 200 schon 10 Sekunden...
Bei Film 300 sind es die 15 Sekunden .

Meine Test Datenbank hat nur gut 350 Filme , wenn welche mit über 1000 testen kann es ja sein das es wohl noch viel länger dauert bis sich das Fenster schließt,

Kann das bestätigt werden ?
versucht mal euren ersten Film zu bearbeiten .

@Tbengel    benutzt du eine größere Test Datenbank oder eine kleine ?


Beim Verschieben ist es so ,  Film 350 auf 1 schieben dauert die 15 Sekunden  , schiebe ich den dann wieder auf 350 geht es sofort .

tbengel

@pudding: ... in meiner Datenbank sind mehrere 1000 Filme drin und es geht bei mir die ersten 12 Filme hintereinander immer gleich schnell, erst nach dem 12ten Film wird es langsamer. Dies liegt aber am Speicher, der mit Größe der Datenbank voll läuft. Schau mal Deine Arbeitsspeicher-Auslastung und teste nochmal die Version 1.0.0. Dort solltest Du das gleiche Phänomen haben.

Grüße

tbengel

pudding

8 Januar 2019, 01:22:54 #146 Letzte Bearbeitung: 8 Januar 2019, 01:25:15 von pudding
nein , bei der 1.0.0.  ist es nicht

Mein Arbeitsspeicher zeigt nichts auffälliges

tbengel

Vergleiche mal den Arbeitsspeicher bei der 1.0.0 und bei der 1.1.0 mit den selben Aktionen ...

Grüße

tbengel

pudding

Kein Unterschied , bei beiden Versionen zeigt der Arbeitsspeicher nichts auffälliges

Old.Obelix

@tbengel

Also wie gewünscht, genaue Beschreibung: (Datenbank hat über 10.000 Einträge)

1.   Entpacke zip
2.   Kopiere MyMDb-CE.V.1.1.0 in Programme(x86) in den Ordner von MyMDb.V.3.6
3.   Lösche im Dataverzeichnis - mymdbce.properties
4.   Lösche im Dataverzeichnis - mymdbce.script
5.   Starte MyMDb.V.1.1.0

Filme Hinzufügen:

1.   Gehe auf Film Hinzufügen
2.   Gebe z.B. Marshall ein
3.   Wähle Marshall 2017 aus
4.   Film wird gefunden und in bearbeiten geöffnet
5.   Egal was ich nun editiere, ob Lagerort, Kommentar oder ......
6.   Anschließend klicke ich auf Speichern
7.   Fenster schließt nicht und Button Speichern bleibt gedrückt und aktiv angezeigt
8.   Benden des Programms ist nur noch über Task Manger möglich, indem ich den JAVA- Prozess beende.

Gleiches Procedere bei MyMDb-CE.V1.0.0, alles Funktioniert :D

Nachfolgendes betrifft nur MyMDb-CE.V1.1.0

Film Bearbeiten:

1.   Wähle Film aus, z.B. Achterbahn
2.   Bearbeiten Fenster öffnet
3.   Klicke z.B. auf abbrechen & nächster, es funktioniert

Erneuter Versuch Film Bearbeiten:

1.   Wähle Film aus, z.B. Against the Wall
2.   Bearbeiten Fenster öffnet
3.   Egal was ich nun editiere, ob Lagerort, Kommentar oder ......
4.   Anschließend klicke ich auf Speichern oder Speichern & nächster
5.   Fenster schließt nicht, der jeweilig gedrückte Button bleibt gedrückt und aktiv angezeigt
6.   Benden des Programms ist nur noch über Task Manger möglich, indem ich den JAVA- Prozess beende.

Verschieben auf neue Position:

1.   Wähle Film aus, z.B. Stirb Langsam
2.   Bearbeiten Fenster öffnet
3.   Gebe neue Nummer an
4.   Anschließend klicke ich auf Speichern oder Speichern & nächster
5.   Fenster schließt nicht, der jeweilig gedrückte Button bleibt gedrückt und aktiv angezeigt
6.   Benden des Programms ist nur noch über Task Manger möglich, indem ich den JAVA- Prozess beende.

Habe deine nochmals zugesendete Version erneut getestet und es ist genau dasselbe.

Bei der 1.1.0 Version, fährt der Arbeitsspeicher nach oben, bei der 1.0.0 Version wird es ab ca. dem 10. Neueintrag kritisch und führt sogar zum Absturz.

Da pudding unter 7 Pro testet werde ich mich jetzt auf Windows 10 Pro einschießen.

LG
Old.Obelix