MyMDb-CE 1.X.X (Fragen / Bugs / Wünsche)

Erstellt von tbengel, 24 Dezember 2018, 09:22:15

Vorheriges Thema - Nächstes Thema

0 Mitglieder und 5 Gäste schauen sich dieses Thema an.

cmal

ja, das Icon ist größer: 50x50
aber selbst wenn ich die Quickinfo von 450 Pixel auf 500 verbreitere, wird es nicht angezeigt; da ist Platz genug:



aber eigentlich wollte ich bitten diese Icons nicht horizontal, sondern vertikal darzustellen (in einer Spalte) neben dem Cover; das spart Platz...
dabei ist mir aufgefallen, dass, wenn ich das Cover verbreitere bis die Icons nicht mehr nebendran passen, sie angeschitten werden; beide, das reguläre und das "zu große"...



das passiert aber nicht bei allen Filmen... verwirrend...


tbengel

9 September 2020, 22:06:52 #1201 Letzte Bearbeitung: 9 September 2020, 22:09:49 von tbengel
Hallo cmal,

die Icons werden immer, wenn Platz ist, auf der rechten
Seite angezeigt. Wenn nicht, dann unter dem Cover.

Die Anordnung ist hierbei immer von links nach rechts,
also:

1 2
3 4
5 6

Du denkst nur an Deine zwei Icons, aber es muss hierbei immer damit
gerechnet werden, dass mehr als zwei Icons angezeigt werden können.

Warum ist dies für Dich ein Problem, Du hast doch auf der rechten Seite
des Covers genug Platz?

Das Abschneiden passiert, wenn Du überlange Cover verwendest ... Nenne
mir mal bitte die Maße Deines Bildes, dann kann ich es reproduzieren.

Weiterhin ist die Icon-Anzeige auf "40 x 40" angepasst. Deshalb nutze
auch Icons in dieser Größe, sonst wirst Du immer wieder diesbezügliche
Probleme bekommen.

Grüße

tbengel

cmal

...naja, diese 10 Pixel mehr machen halt einen großen Unterschied in der Bild-Güte... schließlich geht es hier um Eye-Candy... und diese altbackene Anaglyphenbrille, bäh....  :denk3:

die Cover sind 600x800, das ist die historische Standardgröße für MKV...

vielleicht hilft es, wenn ich meinen Use-Case schildere: ich benutze die Datenbank nicht um meine Filme im Arbeitszimmer zu verwalten (dort füttere ich sie nur); wirklich genutzt wird sie von der Couch aus, wo ich auf einem 65" Plasma aus 3,5m Entfernung mich entscheide welchen Film oder Serie ich schauen möchte; dazu braucht es gut aufgelöste Cover, Icons und lesbaren Text; daher ist auch die Quickinfo, neben der Cover-Ansicht, für mich das zentrale Feature.

tbengel

10 September 2020, 09:38:10 #1203 Letzte Bearbeitung: 10 September 2020, 14:10:03 von tbengel
Hallo cmal,

auch dies bekomme ich bei mir (trotz der Maße von 600 x 800) nicht reproduziert:



Ich schätze mal, es liegt immer noch an Deinem zu großen 3D-Icon.

Da Du in Deinen Anpassungen (sagen wir mal) sehr speziell bist,
verbleiben wir am Besten so.

Bevor Du weitere Unstimmigkeiten meldest, nutze zuvor eine jungfräuliche
MyMDb-CE Version ohne alle Deine speziellen Anpassungen (seien es Icons
oder Script-Änderungen) und versuche dort, Dein Problem zu reproduzieren.

Nur wenn dies möglich ist, kann ich es auch bei mir nachvollziehen und
gegebenenfalls fixen.

Grüße

tbengel

cmal

@tbengel
ja, klar, es liegt am größeren 3D-Icon; ich dachte/hoffte, dass ich in meinem letzten Post mit dem Gewinsel über die "10 Pixel weniger" das angedeutet habe; ich darf nicht mehr so spät schreiben... da nimmt mein Hirn Abkürzungen...

mit anderen Worten: wäre es nicht möglich diese Icon-Größe flexibler zu gestalten (so wie es bei den Covern auch die "reguläre" in die "individuelle" gibt, bzw. toleriert wird)?

Grüße

tbengel

Hallo caml,

Zitatmit anderen Worten: wäre es nicht möglich diese Icon-Größe flexibler zu gestalten (so wie es bei den Covern auch die "reguläre" in die "individuelle" gibt, bzw. toleriert wird)?
Nop, diesbezüglich mache ich Dir keine Hoffnungen, denn eine solche Flexibilität
ist mit einem enormen Programmieraufwand verbunden. Der nächste will dann Icons
in 80 x 60 und dann noch einer 10 x 10. Alleine das wir die Möglichkeit bieten
Icons auszutauschen ist nicht selbstverständlich ... dann kann man zumindest
erwarten, dass die Maße eingehalten werden (ehrlich gesagt bin ich auch nicht
davon ausgegangen, dass jemand Icons mit anderen Maßen verwendet, dafür stehen
doch schließlich die Original-Maße bei jeder Grafik dabei).

Bei den Medientypen, FSK's und Filmpreisen prüfen wir die Abmessungen, da wir dort
kein Risiko eingehen wollten. Vielleicht macht es Sinn, auch bei den anderen Grafiken
die Vorgaben zu checken ... mal schauen.

Also von mir wird es eine derartige Anpassung nicht geben ... wenn Du Dich mal
in eine Programmiersprache einarbeiten würdest und Dich mal mit GUI-Programmierung
auseinander setzen würdest, dann könntest Du besser verstehen welcher Aufwand hinter
solchen Anpassungen steht ...

Ich habe die letzten Tage (meines Urlaubs :happy2:) nur damit zugebracht, das
Bearbeiten-Fenster und die Detail-Box pixelgenau anzugleichen. Die Unterschiede
sind minimal, aber der Zeitaufwand ist enorm ...

Wie gesagt, mach aktiv hier mit und unterstütz uns mit Deinem Wissen, dies würde
das Projekt vorwärts bringen ... nur zu hoffen, dass man möglichst flexibel auf
Deine, eher ausgefallenen, Wünsche reagiert, reicht da leider nicht aus ...

Grüße

tbengel

cmal

Zitat von: tbengel nach 10 September 2020, 22:31:51Hallo caml,

Zitat von: undefinedmit anderen Worten: wäre es nicht möglich diese Icon-Größe flexibler zu gestalten (so wie es bei den Covern auch die "reguläre" in die "individuelle" gibt, bzw. toleriert wird)?
Nop, diesbezüglich mache ich Dir keine Hoffnungen, denn eine solche Flexibilität
ist mit einem enormen Programmieraufwand verbunden....

na guuuuut....

cmal

@tbengel
Problem:
meine Datenbank ist auf dem NAS;
wenn in den Config-Ordner auch auf das NAS verlege, werden zwar die vier Text-files raufkopiert (config.txt, config_FILME.txt, config_STANDARDPROFIL.txt, config_STARTDB.txt) und im Ursprungs-Ordner der exe eine configdir.txt erstellt, aber das Programm startet mit einer leeren Datenbank...
das hat schon mal mit der 1.9.1. funktioniert...

tbengel

13 September 2020, 08:40:21 #1208 Letzte Bearbeitung: 13 September 2020, 13:27:03 von tbengel
Hallo @cmal,

mit der Änderung des Config-Pfades wird nur der Pfad angepasst, das Kopieren
desselben musst Du manuell machen. Also überschreibe die config-Dateien auf
Deinem NAS mit den config-Dateien aus Deinem Arbeitsverzeichnis und dann klappt
alles.

Zitatdas hat schon mal mit der 1.9.1. funktioniert...
Dies kann nicht sein, da die Config in der Version 1.9.1 noch
nicht in ein anderes Verzeichnis verschoben werden konnte (siehe
Changelog).


Grüße

tbengel

Mongoo

Ich habebisher noch mit einer alten Mymdb 3.5.3 gearbeitet. Habe nun diese version gefunden. Habe dann versucht eine Backup meiner 3.5.3 hier einzuspielen. er sagt dann erfolgreich eingespielt. sagt dann neustart. dann die Datenbank Bluray wurde aktuallisiert und ich soll neustarten. dannach habe ich nichts in der liste. das Backup wurde ignoriert. Sind die backups nicht kompatibel`?

tbengel

@Mongoo:
ZitatSind die backups nicht kompatibel?
Bisher haben wir jede MyMDb lauffähig bekommen ...

Schon mal geschaut, ob Du die richtige Datenbank ausgewählt hast?

Grüße

tbengel

tbengel

Hallo,

es lag bei @Mongoo's Datenbank wieder mal daran, dass dort der Wert NULL in der
Tabelle stand, diese Werte wurden mittels REPLACE von ", NULL" auf ", ''" (in der
Datei mymdbCE.script) ersetzt.

Scheint also so, dass in der alten MyMDb3.5.3 noch diesbezügliche Einträge erlaubt waren,
während diese in MyMDb3.6 nicht mehr vorhanden sind.

Nur falls jemand in Zukunft ein ähnliches Problem hat, wobei soviele MyMDb3.5.3 Nutzer
sollte es nun wirklich nicht mehr geben :happy2:.

Grüße

tbengel

franklyn

2 November 2020, 00:36:36 #1212 Letzte Bearbeitung: 2 November 2020, 01:00:59 von franklyn Grund: Prüfung
Erst jetzt hatte ich die Ruhe & Zeit mich mit der neuen Version 1.93 zu beschäftigen und einen ausführlichen Bericht zu erstellen ... 

Aufgrund des fehlenden Versionshistorie-Fensters bei meinem "Update" mithilfe einer Backup-Datei von MyMDb 3.6 und der deutlichen Warnung, dass wenn dieses Fenster nicht erscheint, es in der Zukunft möglicherweise Probleme mit MyMDb-CE geben könne, habe ich nun jeden einzelnen Schritt aufgeführt um eine Analyse und hoffentliche Fehlerbeseitigung zu ermöglichen.
Leider kommen dadurch viele Worte zustande... wen es nicht interessiert hört HIER auf zu Lesen...


Eine Änderung für die nächste Programmversion sollte unbedingt vorgenommen werden, ich finde es hat sich hier in die 1.93 ein NoGo! eingeschlichen.
MyMDB-CE 1.93 startet ERST NACHDEM man einen unnützen Zwischen-Klick ausgeführt hat, wenn man nicht online ist. Was soll das denn plötzlich? Wenn ich nicht online bin, weiß ich das in der Regel ...
Wenn ich aktiv einen neuen Eintrag online erstellen oder etwas online aktualisieren lassen möchte ist es natürlich erforderlich auch online zu sein, logo.
Ich finde in allen anderen Fällen hat ein Programm von sich aus schlicht die Fresse zu halten und nicht UNGEFRAGT einfach eine Verbindung ins Netz zu starten, mho.
Gute Programme sollten eigentlich so programmiert sein, dass sie NUR DANN eine Internetverbindung herstellen (wollen), wenn diese auch auch tatsächlich und funktionsbedingt BENÖTIGT wird.
Auch bei der 1.91 und der 1.92 bemerkte ich dieses unrühmliche Verhalten aber zumindest starten diese Versionen ohne "Internetverbindung fehlgeschlagen-MELDUNG" und obligatorisch notwendigen Bestätigungsklick. Jedes Mal einen extra Zusatzklick beim Programmstart nervt.

Als Anregung für eine nächste Version: Abänderung dieses "automatisch online Wollen" zu "nur dann online wollen, wenn tatsächlich notwendig". Und diese überflüssige Klick-Bestätigungs-Fenster abschaffen oder in den Einstellungen eine Möglichkeit zur De-aktivierbarkeit machen wäre schon geil.
Oder habe ich in den Einstellungen diesbezüglich etwas übersehen?  :denk:





So, nun aber zum eigentlichen Thema mit dem NICHT erscheinenden UPDATE-FENSTER mit der "Versionshistorie"

------------

Neu"Installation" von 1.9.3 mit anschließender Backup-Einspielung (Backup-Datei mit 3.6 erstellt)
System: WIN-7-Ultimate 64bit



1. Zip in den Ordner kopiert in dem letztlich der entpackte "MyMDb-CE"- Ordner liegen soll.
In meinem Fall in einen selbst angelegten Ordner "Eigene Programme". -  Also NICHT in einen ProgrammOrdner des Systems.
DAHER auch keine Rechteänderung an der "MyMDb-CE.exe"


2. Zip entpackt, der Ordner "MyMDb-CE" wurde erstellt und in "MyMDb-CE 1.93" umbenannt.
Zip gelöscht.


3. beiliegende Datei: "MyMDb-CE_Update-Anleitung.pdf"
streng nach "Methode 1" der "Schnellanleitung zum Versionsupdate" "Backup-Datei von 3.6 einspielen"


4. Punkte 1-6 ausgeführt
- bei Punkt 2 "MyMDb-CE.exe" gestartet
- MELDUNG: "Internetverbindung fehlgeschlagen"
- "OK- Button" geklickt,
- MyMDB-CE 1.93 startet (1x), Hauptoberfläche alles leer

- vorhandenes Backup von 3.6 einspielen,
- "Warnungsfenster" erscheint
- "Ja" Klick

- MELDUNG: "Backup erfolgreich eingespielt..."
- OK-Klick
- MELDUNG: "Internetverbindung fehlgeschlagen"
- OK-Klick
- MyMDB-CE 1.93 wird beendet, aber KEIN (!!) Neustart wie in der "Update-Anleitung" angekündigt  :denk:



5.
- Da KEIN automatischer Neustart dann eben manuell... (2x)
- MELDUNG: "Internetverbindung fehlgeschlagen"
- OK-Klick
- MyMDB-CE 1.93 startet, leere Oberfläche

(Ich sehe die identische "leere Übersicht" wie beim ersten Programmstart und es erscheint KEIN UPDATE-FENSTER mit der "Versionshistorie" - Laut Schnellanleitung sollte diese Fenster ja eigentlich erscheinen....  tut´s hier aber schlicht nicht !!...)  :denk:

- MyMDB-CE 1.93 manuell beendet




5a. Datei & Ordner-Check zu DIESEM Zeitpunkt:

- C:\Eigene Programme\MyMDb-CE-1.93\config :
    -config.txt (16KB)
    -config_STANDARDPROFIL.txt (4KB)
    -config_STARTDB.txt (3KB)

- C:\Eigene Programme\MyMDb-CE-1.93\logs :
    -leer

-C:\Eigene Programme\MyMDb-CE-1.93\data :
    -images-Ordner (86,7MB)
    -mymdb.properties (1KB)
    -mymdb.script (14.748KB)
    -mymdbce.log (1KB)
    -mymdbce.properties (1KB)
    -mymdbce.script (2KB)

    - -C:\Eigene Programme\MyMDb-CE-1.93\data\images :
        -cover-Ordner (6,47MB)
        * (hier liegen  jpg´s, die in 3.6 manuell selbst angelegten "zusätzlichen" Front- und Back-Cover, die im
           Bearbeitungsfenster unter "eigene Cover" sichtbar sind. ?)
        * Die Bilder dort haben eine Höhe von 400px oder von 500px, die Breite ist sehr verschieden

        -movies-Ordner (80,2MB) (hier legen offensichtlich die von der Backup-Einspielung abgelegten kleinen
         Cover ?)
        * dort sind jpg´s drin  - Das kleinste jpg ist 60x30px (sehr viele 60x...), ein 81er, ein 96x ein 97x, zwei 98x,
          fünf 100x, achtzehn 110x ..... - die meisten aber 120x
        * (was ich hier ebenfalls festgestellt habe: häufig liegen hier mehrere IDENTISCHE Filmcover -identische
           Abmessungen, Dateigröße, Dateiname- einziger Unterschied ist die dem Dateinamen angefügte 13stellige
           Nummerierung - Komischerweise sind bei manchen Covern nur eine Datei, dann zwei, aber auch 3, das
           Maximum scheint 4 identische JPG´s zu sein....)

        -thumbs-Ordner -  leer-





6. Handbuch S.10 "für ehemalige Nutzer von MyMDb 3.6""

("Nach dem Neustart des Programms schließt Ihr MyMDb-CE wieder. Jetzt geht Ihr im Programmverzeichnis in den Unterordner ,,data"... Hier  müssen  nun  die  beiden  Dateien  ,,mymdbCE.*"  gelöscht  werden ... Danach das Programm wieder starten und die alte MyMDb-Datenbank wird automatisch für MyMDb-CE konvertiert.")

*DAS steht leider NUR im "Handbuch" auf S.10
(Meine Empfehlung: Das sollte UNBEDINGT sowohl bei der Update-Anleitung UND AUCH der Start-Anleitung stehen.... )


- beide Dateien aus dem data-Ordner gelöscht (mymdbce.properties + mymdbce.script)




7. nach der Dateilöschung

- MyMDB-CE 1.93 gestartet (3x) 
- MELDUNG: "Internetverbindung fehlgeschlagen"
- OK-Klick
- MyMDB-CE 1.93 startet,  Ergebnis:

* Es wurde leider EBENFALLS KEINE UPDATE-MELDUNG sichtbar - nada, niente, nix!  :denk:
* Das Backup wurde offensichtlich teilweise ausgeführt, die Programmoberfläche ist NICHT mehr leer sondern
  zeigt meine alten Einträge.
* Es sind aber KEINE COVER (Reiter "Übersicht", Hauptansicht) in der "SPALTE COVER" sichtbar, nur dieses
  augenterrorisierende "No Cover" Symbolbild (das ich mittlerweile durch ein weißes GIF ersetzt habe)
* Links in der Übersicht eines angewählten Eintrags ist das entsprechende Cover allerdings korrekt zu sehen.
* Im Reiter "Cover" sind alle Cover korrekt zu sehen
* Im Bearbeitungsfenster eines Eintrags ist das Cover korrekt zu sehen




9. Manuelles Hinzufügen eines Cover-Bildes

(Nach dem manuellen Hinzufügen eines Cover-Bildes erscheint erst noch ein Abfragefenster das zwar weitere Fragern aufwirft aber meiner Meinung nach ebenfalls komplett überflüssig ist:
"Die OFDb-URL"http://www.ofdb.de/film/292929,xyfilm"; entspricht keinem gültigen OFDb-Link. Soll das Speichern dennoch fortgesetzt werdfen? JA-NEIN-Klick"

Es nervt gewaltig, wieder einmal muß man unnütz rumklicken, genau wie die unnützen "Internetverbindung fehlgeschlagen MELDUNGEN". Kann man diese "Warnmeldungen" irgendwie deaktivieren ???)  :denk:


* Nachdem ich ein Cover im Bearbeitungsfenster unter "Bild auswählen" manuell hinzugefügt habe und zusätzlich auch gehorsamst auf JA geklickt habe, sehe ich in der Hauptansicht in der Spalte "Cover" nun dieses soeben hinzugefügte Cover.

* Alle anderen Einträge sind weiterhin mit diesem "No Cover" gekennzeichnet.

*C:\Eigene Programme\MyMDb-CE\data\images\thumbs
ist nun auch nicht mehr leer, sondern "xyfilm_c_self_1597368393375.jpg" ist als einziger Eintrag sichtbar.


* ein Experiment:
Wiederhole ich nun bei dem selben Eintrag nun "nocheinmal" das Hinzufügen des identischen Bildes wie zuvor ... habe ich in dem thumbs-Ordner nun eine zweite datei "xyfilm_self_1597370422378.jpg ... obwohl ja nur "eine" tatsächlich "genutzt" wird.  :denk:
Es bleibt also überflüssiger Datenschrott zurück, der - in Massen vorhanden -  möglicherweise mal irgendwelche Probleme bereiten könnte ???  :denk:




10. nachträgliche Bemerkung, nach etwas Stöbern und Ausprobieren

Seltsamerweise sind nach Umstellungen in den Einstellungen:

- Tabellen-Ansicht / Zeilenhöhe und Anzahl Zeilen pro Zelle 120/8
- Breite Cover auf Übersicht 80
- Quick-Info Panel: eigenen Kommentar auf minimale Zeichen (250), Filmbeschreibung auf 330 Z max Länge und
  Schauspieler Z 220 max Länge

(das ist woran ich mich erinnere, möglicherweise habe ich noch weitere "Pixel-Größen" woanders abgeändert ?)

und dem obligatorischen Programmneustart nun plötzlich alle Cover auch in der Übersicht zu sehen !!    :denk2:


Ich ärgerte mich darüber, dass das quick info panel leider keine "reservierte Höhe" mehr zum Einstellen hat wie noch die 1.91 (ist genial für gleiches Aussehen/"untere"Höhe bei allen Einträgen, unabhängig von der jeweiligen Menge des Textes vom plot)
Das ist alles recht seltsam, denn vorher hatte ich die 1.93 bestimmt 20-30 mal gestartet, um mir etwas in den Einstellungen anzusehen und zu konfigurieren.
Es wurden also etliche "Einstellungs-Übernahme-Neustarts" vorgenommen OHNE das vorher auch sämtliche Cover in der Übersicht angezeigt wurden - es war immer nur das eine, selbsthinzugefügte Cover zu sehen.

Ich kann da keine "Logik" mehr erkennen wie und wieso das plötzlich scheinbar "in Ordnung"  gekommen ist.
Mir bleibt ein fahler Nachgeschmack und Sorge wegen des immer noch nicht augetauchten "Versionsupdate-Fenster", dass ich, im Gegensatz zu den vielen überflüssigen Meldungen, sehr gerne einmal wegklicken möchte... :smiley:

tbengel

Hallo @franklyn,

mir ist bei alle dem Durcheinander nicht klar, was Du eigentlich willst.

Herausgelesen hab ich nur, dass Dich stört, dass die Internetverbindung
abgeprüft wird, was jedoch sinnbefreit ist, da Du ohne Internetverbindung
keine Filme hinzufügen kannst und auch nicht erfährst, ob es neue Updates
gibt (was er genau da tut, wo Du die Meldung wegen dem fehlgeschlagenen Zugriff
auf das Internet erhälst) und das Update-Fenster kann natürlich auch nicht
aufgehen, da sein Inhalt auf dem MyMDb-CE Server (im Internet :happy3:) liegt.

Vielleicht solltest Du für das Programm das Internet freigeben und Dich
danach nochmal sammeln und kurz aufschreiben, welche Wünsche Du noch hast.

Grüße

tbengel

franklyn

2 November 2020, 15:22:16 #1214 Letzte Bearbeitung: 2 November 2020, 15:26:47 von franklyn Grund: korrektur
@ tbengel

Vorweg erstmal:  PEACE. :love:

sorry, ich dachte das oben sei gerade genau das Gegenteil von "Durcheinander", da ich jeden Schritt NACHEINANDER, GENAU, also step by step aufschreibe und NICHTS vergessen wollte.
(für eine Fehler-Analyse und zur Problemlösung). 

Ist wohl irgendwie nicht so ganz gelungen? :bang:

Es hilft vielleicht eine grundsätzlichen Erläuterung, die ich hier an anderer Stelle schon mal beschrieben habe:
Die 3.6er habe ich auf einem Online-Rechner betrieben nur um neue Filme zu aktualisieren.
Auf einem Offline-Rechner habe mit dem Programm dann tatsächlich "gearbeitet".
Mit der "Backup-Datei" war das wunderbar möglich.
Genauso möchte ich nun mit MyMDb-CE weitermachen.

Vielleicht gaaanz in Ruhe noch einmal durchgehen, ganz ohne Hektik ???  :love:

Hast nicht sogar Du an verschiedenen Stellen geschrieben, dass es GANZ WICHTIG sei,
dass man nach einem "Update" von 3.6 auch unbedingt dass "Updatefenster" sehen muss 
- denn wenn nicht, es für die Zukunft und weiteren updates nicht SICHER sei, dass immer alles gut funktioniert ???

Es gab/gibt doch noch (wenige) andere User die ebenfalls keine Updatemeldung sahen...

Gerade diese obige (deine?) Aussage und im Besonderen auch Text und die Bilder der Updateanleitung lassen mich befürchten:
Ich nix sehen Updatefenster, ich morgen vielleicht Probleme mit MyMBd-CE..


WENN mann allerdings das Updatefenset NUR DANN sieht, wenn man bei dem Update gleichzeitig auch online ist, 
DANN hat sich ja DIESER Spuk gerade in Luft aufgelöst. Wär ja schön...


Das sollte dann vielleicht auch mal an irgendeiner Stelle erwähnt werden.
Habe ich bisher nämlich noch nirgendwo gelesen, oben bei Dir gerade zum allerersten Mal !

Die meisten Programme, die ich kenne, geben nach der Installation eine positve Installationsbestätigung heraus OHNE mit dem Internet verbunden sein zu müssen.


Wenn das also tatsächlich so ist (?) dann mein Text-Vorschlag für die "Updateanleitung" und das Handbuch:

"Du siehst das Update-Fenster aber nur dann, wenn Du bei der Installation/ dem Update auch online bist.
Bist Du bei dem Update offline, wirst Du das Fenster nicht sehen, da es nicht im Programm hinterlegt, sondern nur auf dem MyMDb-CE Server liegt"




Nun ja, ich dachte ja, ich war oben bereits "gesammelt" doch sag ich mal ganz kompakt was ich oben wollte
(und weiterhin will):

- Sicherstellen dass die bei mir fehlende Updatemeldung keine zukünftigen Probleme verursacht und das Update
  korrekt funktioniert hat.

- Das die derzeit erzwungenen Bestätigungs-Klicks beim Programmstart wieder  aufhören/abstellbar sind
  (das war weder bei 1.91 oder 1.92 noch bei der alten 3.6 so wie jetzt in der 1.93).

- Gerne verstehen wollen, warum ich erst beim x-ten Programmstart die Cover auch in der Übersicht gesehen
  habe und nicht schon sofort nach Löschung der beiden Dateien (oder ob das ein Problem darstellt).

- Gerne im "quick-info panel" wieder eine "reservierte Höhe" selbst bestimmen kann.

- Ist oben bei 9. mein unter "Experiment" beschriebenes Verhalten "normal" oder deutet das auf Fehler hin?

- MyMNd-CE genausogut auch offline funktioniert wie MyMBd 3.6



Ist Dir mein obiger Beitrag jetzt etwas klarer geworden?

tbengel

Hallo frankly,

ZitatIst Dir mein obiger Beitrag jetzt etwas klarer geworden?
Wesentlich klarer ...

Zitat- Sicherstellen dass die bei mir fehlende Updatemeldung keine zukünftigen Probleme verursacht und das Update
  korrekt funktioniert hat.
- Das die derzeit erzwungenen Bestätigungs-Klicks beim Programmstart wieder  aufhören/abstellbar sind
  (das war weder bei 1.91 oder 1.92 noch bei der alten 3.6 so wie jetzt in der 1.93).
- MyMNd-CE genausogut auch offline funktioniert wie MyMBd 3.6
Ich schau mal, ob ich zuerst allgemein prüfe, ob eine Internetverbindung überhaupt da ist und dann
dementsprechend reagiere, ... aber Du weiß schon, dass Deine "Online-Phobie :happy3:" nicht gerade
mehrheitstauglich ist, oder  :happy2:

Zitat- Gerne verstehen wollen, warum ich erst beim x-ten Programmstart die Cover auch in der Übersicht gesehen
  habe und nicht schon sofort nach Löschung der beiden Dateien (oder ob das ein Problem darstellt).
- Ist oben bei 9. mein unter "Experiment" beschriebenes Verhalten "normal" oder deutet das auf Fehler hin?
Bekomme ich beides nicht reproduziert ...

Zitat- Gerne im "quick-info panel" wieder eine "reservierte Höhe" selbst bestimmen kann.
Dies wurde gerade entfernt, da es unsinnig ist, längere Texte abzuschneiden und kurze
Texte mit Leerraum zu füllen. Was bringt Dir dies für Vorteile? Nun kannst Du bestimmen
wieviele Zeichen maximal angezeigt werden sollen und die Höhe passt sich dynamisch
an (was ich damals in der Version 1.9.0 noch nicht umgesetzt hatte, da diese Dynamic
nicht einfach zu programmieren war). Also welchen Vorteil hast Du durch angezeigten
Leerraum?

Grüße

tbengel

franklyn

3 November 2020, 03:51:14 #1216 Letzte Bearbeitung: 3 November 2020, 04:08:25 von franklyn
Zitat von: tbengel nach  2 November 2020, 22:23:45aber Du weiß schon, dass Deine "Online-Phobie :happy3:" nicht gerade
mehrheitstauglich ist, oder  :happy2:
Ist absolut keine Phobie, da verstehst du mich völlig falsch. Ich bir nur sehr oft auch offline und habe an meinem Arbeitsplatz nur einen Offlinerechner der auch nicht ins Netz darf. Das ist absolut gut so und sehr empfehlenswert in vielerlei Hinsicht.

Man kann sehr gut offline mit MyMDb arbeiten, Das allereinzige notwendige online ist doch nur die Zeit, in der ich neue Filme meinem Datenbestand hinzufügen will. That´s it all.

Warum sollte ich denn online sein, wenn ich gerade keine neuen Filme einpflege, von mir aus sogar mit Laptop im Wald? Dieser immeronlineseinmüssentagundnachtundauchamwochenende macht doch auf Dauer nur meschugge in der Rübe und man verwandelt sich schnell zum Junkie, der ohne seine tägliche Dosis von online nicht mehr klarkommt.
Fahr mal mit mehreren Kids ein paar Tage ans Meer und nehm denen ihre onlines ab. Die rasten erst mal komplett aus und sind voll auf Entzug. Die haben erstmal sowas von keinem Spaß, da staunste nur noch... Nach ein paar Tagen unterhalten die sich auch wieder mehr untereinander mit dem Mund. Erstaunlich!


Zitat von: tbengel nach  2 November 2020, 22:23:45Bekomme ich beides nicht reproduziert ...
Wie sieht denn Dein thumbs-Ordner aus? Was ist denn da bei Dir drin?




Zitat von: tbengel nach  2 November 2020, 22:23:45Dies wurde gerade entfernt, da es unsinnig ist, längere Texte abzuschneiden und kurze
Texte mit Leerraum zu füllen. Was bringt Dir dies für Vorteile? Nun kannst Du bestimmen
wieviele Zeichen maximal angezeigt werden sollen und die Höhe passt sich dynamisch
an (was ich damals in der Version 1.9.0 noch nicht umgesetzt hatte, da diese Dynamic
nicht einfach zu programmieren war). Also welchen Vorteil hast Du durch angezeigten
Leerraum?
Unnsinnig ??? Seh ich ganz anders.


Der Vorteil liegt daran, dass

die OFDb-                  IMDb-
die             Eigene Wertung
die Symbole    Detailansicht
und                   der Filmlink

quasi
a) einen grafischen Block bilden , der
b)  ZUDEM IMMER AN DER GLEICHEN STELLE des Monitors ist

Man muß weniger auf Veränderugen achten und die Maus oder das Auge fliegt quasi blind und trifft dennoch das Ziel, da es ja auch immer an der gleichen Stelle ist.
Sieht einfach besser aus wenn sich rechts unten "nix bewegt"

Kannst Du wahrscheinlich nicht nachvollziehen, dass ich das beruhigender finde, oder etwa doch ? :happy3:

lieben Gruß
franklyn

tbengel

Hallo franklyn,

ZitatWie sieht denn Dein thumbs-Ordner aus? Was ist denn da bei Dir drin?
Dort gibt es zu jedem Bild im Ordner "movies" genau ein thumbs_.* Äquivalent.

Falls bei Dir dort zu viele Bilder sein sollten (was durchaus passieren kann), können
diese mittels: Extras - "Lösche ungenutzte Cover" automatisch entfernt werden, was übrigens
generell geschieht, sobald Du ein Backup Deiner Datenbank machst ...

ZitatKannst Du wahrscheinlich nicht nachvollziehen, dass ich das beruhigender finde, oder etwa doch ? :happy3:
Nicht so richtig, da ich sinnlosen Leerraum nervender finde, als verschobene Felder,
aber glücklicherweise sind die Menschen ja im Geschmack verschieden ... ich schau mal
was ich machen kann.

Grüße

tbengel


franklyn

@tbengel


Zitat von: tbengel nach  3 November 2020, 12:58:25
Zitat von: undefinedWie sieht denn Dein thumbs-Ordner aus? Was ist denn da bei Dir drin?
Dort gibt es zu jedem Bild im Ordner "movies" genau ein thumbs_.* Äquivalent.

Falls bei Dir dort zu viele Bilder sein sollten (was durchaus passieren kann),


Du bist lustig. Ich habe dort, wie ich oben schrieb, NUR die beiden "manuell neu hinzugefügten" Cover-jpg´s
Also exakt zwei Dateien sind in meinem thumbs-Odner, mehr nicht


Weil mir das komisch vorkam .... hab ich ja so genau meine Orrner erwähnt:

Zitat von: franklyn nach  2 November 2020, 00:36:36-thumbs-Ordner -  leer-

siehe auch:

Zitat von: franklyn nach  2 November 2020, 00:36:36*C:\Eigene Programme\MyMDb-CE\data\images\thumbs
ist nun auch nicht mehr leer, sondern "xyfilm_c_self_1597368393375.jpg" ist als einziger Eintrag sichtbar.

und:
Zitat von: franklyn nach  2 November 2020, 00:36:36Wiederhole ich nun bei dem selben Eintrag nun "nocheinmal" das Hinzufügen des identischen Bildes wie zuvor ... habe ich in dem thumbs-Ordner nun eine zweite datei "xyfilm_self_1597370422378.jpg ... obwohl ja nur "eine" tatsächlich "genutzt" wird.  :denk:
Es bleibt also überflüssiger Datenschrott zurück, der - in Massen vorhanden -  möglicherweise mal irgendwelche Probleme bereiten könnte ???  :denk:


Hab ich jetzt also ein Problem oder nicht ?

tbengel

Hallo franlyn,

wie bereits geschrieben:

ZitatFalls bei Dir dort zu viele Bilder sein sollten (was durchaus passieren kann), können
diese mittels: Extras - "Lösche ungenutzte Cover" automatisch entfernt werden, was übrigens
generell geschieht, sobald Du ein Backup Deiner Datenbank machst ...

ZitatHab ich jetzt also ein Problem oder nicht ?
Also, nein, kein Problem ...

Grüße

tbengel


franklyn

Moin @tbengel

Ich habe irgendwie das Gefühl du mißverstehst mich ???

Ich habe dort nicht zu viele sondern eher zu wenige.

In meinem movies-Ordner sind mehrere Tausend Dateien (jpg).
in meinem thumbs-Ordner sind genau zwei Dateien (jpg).

Bleibt´s bei "No problem" ?

franklyn

@ tbengel

zum Thema "reservierten Höhe":
Zitatda ich sinnlosen Leerraum nervender finde, als verschobene Felder,
... ein Leerraum ist doch so-oder-so vorhanden, wenn z.B. der vorhandene Platz nicht ausgenutzt wird.

Derzeit kommen "am Ende" die Bewertungen und das link-symbol und erst dann
der sich von Eintrag zu Eintrag ändernde Leerraum darunter

Bei einer "reservierten Höhe" bleiben die Bewertungen bei unterschiedlichen Einträgen am gleichen Platz und der Leerraum darüber ändert sich (wenn im plot keine Romane stehen)

tbengel

Hallo franklyn,

Zitat von: undefinedIch habe irgendwie das Gefühl du mißverstehst mich ???
Jep, komplett missverstanden, dann hast Du natürlich ein Problem, denn
dann hat das Versionsupdate nicht geklappt (bestimmt, weil Du nicht
online warst  :happy3:).

Du kannst es beheben, indem Du alle data/images/movies/thumbs_*.* Dateien
in den Ordner data/images/thumbs verschiebst. Dann ist alle wieder bestens,
oder Du machst ein Online-Versionupdate, oder Du wartest auf die Version 2.0
da gibt es dann extra wegen Dir einen MyMDb-CE-Offline-Modus :banana: .

Zitat von: undefined... ein Leerraum ist doch so-oder-so vorhanden, wenn z.B. der vorhandene Platz nicht ausgenutzt wird.

Aber dann ist der Leeraum unten und nicht zwischendrinn, aber auch hier brauchen wir
nicht mehr zu debattieren, da Du ab der Version 2.0 wieder die Möglichkeit haben wirst,
die Höhe für Inhalt, Schauspieler und Kommentar in der Quick-Info selber zu bestimmen :happy2:.

Hoffe, dass damit Deine wundesten Punkte geheilt werden.

Grüße

tbengel

franklyn

@tbengel


Zitat von: tbengel nach  4 November 2020, 12:23:11da gibt es dann extra wegen Dir einen MyMDb-CE-Offline-Modus :banana:

Echt ??? Kein wegklicken mehr von einer Warn-Meldung, noch bevor das Programm startet ??   Das startet dann wieder einfach so durch ?           
:love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love: :love:


Zitat von: tbengel nach  4 November 2020, 12:23:11Jep, komplett missverstanden,
Puh, gut das ich nachgefragt hab.



Zitat von: tbengel nach  4 November 2020, 12:23:11Hoffe, dass damit Deine wundesten Punkte geheilt werden.
Ähm, äh, nun ja, also  - vielleicht gäääbs da ja doch noch was ?  :engel: ... trau mich aber nich mehr so richtig... weil ich Angst hab, dann doch noch vermöbelt zu werden, wenn ich das jetzt auch noch anmerke...



Ich sollte nämlich vielleicht als momentaner Titelträger meine Machtbefugnisse nicht zuuu sehr ausreizen?
Wohlmöglich verursache ich sonst eine Rebellion, die mich dann einfach wegfrisst.
Es ist ja schon ganz fein auf so einem Posten zu sitzen, da sollte man ja vielleicht :ahnung: und weiter so tun als hätte man das doch. Dann behält man auch seine Diäten und andere Privilegien, an denen ich unbedingt, koste es was es solle, mittlerweile festhalten will. Da kann man sich schon dran gewöhnen, wenn´s denn unbedingt sein muß...
So läut das doch überall, oder ? :smile:

franklyn

6 November 2020, 16:04:17 #1224 Letzte Bearbeitung: 6 November 2020, 16:07:47 von franklyn
@tbengel
Ich habe, wie Du mir geraten hast, manuell alle thumb-Dateien aus dem alten 3.6er-movies-Ordner in den ("leeren") 1.93 thumbs-Ordner kopiert.
Ergebnis: ich sehe in der 1.93 (wie zuvor) die bisherigen Cover-Ansichten, nichts hat sich scheinbar geändert, aber ich bin dann ja wohl "updatesicher".

Thanx a lot, für diesen Tip! :smiley:

Ich habe sofort ein Backup erstellt.
Was mich dabei ein wenig wundert:
Meine unter der 1.93 erstellte Backupdatei (.xlg) ist viel kleiner als das alte 3.6er-Backup (ca 70KB zu ca. 100KB).
Liegt das an einer "veränderten Komprimierung" oder deutet das auf Fehler hin ? :denk:

---

Jetzt habe ich das erste Mal auf dem Online-Rechner die 1.93 gestartet, während ich auch online war. :happy3:
Meiner Firewall habe ich den Zugang erlaubt.
Erwartungsgemäß startete 1.93 durch, ohne eine Warnmeldung wegkicken zu müssen.


Zum Testen habe ich einige neue Filme eingetragen - alles funzt, die neuen Filme werden eingetragen. :smiley:
(Ich füge den OFDb-link direkt in das vorgesehene Feld ein und klicke "hinzufügen")

Eine Irritation bleibt:
Unter "Parser Settings" ist die OFDb als "primäre Hauptdatenquelle" ausgewählt.
Bei "Daten durch Sekundärquelle ersetzen" sind nur "Cover" angehakt.

Obwohl ich auf der entsprechenden OFDb-Seite ein Cover für den neuen Film angezeigt bekomme,
wird nicht etwa dieses Cover in meine 1.93 eingefügt, sondern meist ein anderes (von IMDb ?).

Deaktiviere ich unter "Parser Settings" die Cover, und füge danach einen neuen Film hinzu,
wird gar kein Cover geladen, sondern das "No-Cover-Cover" wird bei dem entsprechenden Neueintrag angezeigt.

Ist zwar jetzt nicht die Welt, aber die Cover von OFDb gefallen mir meist VIEL besser...

Was mache ich falsch?  :denk: 


Die Backup-Erstellung und die Einspielung auf dem Offline Rechner in 1.93 klappte reibungslos, alle neuen Filmeinträge sind vorhanden. :respect:

Greetz, franklyn

tbengel

Hallo franklyn,

ZitatLiegt das an einer "veränderten Komprimierung" oder deutet das auf Fehler hin ? :denk:
Schau Dir die beiden Backups einfach mal direkt an, dann wirst Du die Unterschiede sehen.
Einfach das ".xlg" in ".zip" umbenennen und dann entpacken.

ZitatObwohl ich auf der entsprechenden OFDb-Seite ein Cover für den neuen Film angezeigt bekomme,
wird nicht etwa dieses Cover in meine 1.93 eingefügt, sondern meist ein anderes (von IMDb ?).

Deaktiviere ich unter "Parser Settings" die Cover, und füge danach einen neuen Film hinzu,
wird gar kein Cover geladen, sondern das "No-Cover-Cover" wird bei dem entsprechenden Neueintrag angezeigt.
Wenn es auf der OFDb ein Cover gibt, wird es auch übertragen, verwechsel es jedoch
nicht mit den Cover für die unterschiedlichen Fassungen. Weiterhin werden immer
zwei Cover übertragen, sowohl das OFDb-Cover, als auch das IMDb-Cover (wenn vorhanden)
Zwischen diesen kann man dann wechseln und sich das Beste aussuchen (siehe Handbuch).
Ansonsten nenne mir mal ein Film, welche Deiner Meinung nach kein Cover liefert.

Grüße

tbengel

franklyn

Moin tbengel

Zitat von: tbengel nach  6 November 2020, 17:20:37Ansonsten nenne mir mal ein Film, welche Deiner Meinung nach kein Cover liefert.


Bei der oben von mir genannten Konfiguration, wird NIE ein Cover eingefügt.
Dennoch mal Beispiele:

https://ssl.ofdb.de/film/25057,Robot-Monster
https://ssl.ofdb.de/film/33080,Die-Azteken-Mumie-gegen-den-Menschen-Roboter
https://ssl.ofdb.de/film/280571,A-War

... sollte reichen?

tbengel

Hallo franklyn,

Bei mir werden bei Deinen Beispielen sogar jeweils zwei Cover eingefügt,
ein OFDb- und ein IMDb-Cover (Klick auf das Cover in Edit-Box).

Nur bei "A War" findet er nur das OFDb-Cover, obwohl auch ein IMDb-Cover
vorhanden ist, aber dies liegt daran:

Fehler: 06.11.2020 um 17:24 Uhr
A War: https://www.imdb.com/title/tt3830162
cover parsing error

Also alles bestens. Irgendwas machst Du falsch ...

Grüße

tbengel

franklyn

6 November 2020, 18:35:40 #1228 Letzte Bearbeitung: 6 November 2020, 18:37:31 von franklyn
Hi tbengel,

Zitat von: tbengel nach  6 November 2020, 18:29:21Bei mir werden bei Deinen Beispielen sogar jeweils zwei Cover eingefügt,
Bei den selben Einstellungen, wie ich sie oben beschrieben habe?

Zitat von: tbengel nach  6 November 2020, 18:29:21Irgendwas machst Du falsch ...
Ja, das merke ich - aber was denn boß ????


Greetz, franklyn

tbengel

Hallo franklyn,

ZitatJa, das merke ich - aber was denn boß ????
Ich schätze mal, Du hast was in der Config kaputtgebastelt.
Ich denke deine Parsing-Einstellungen passen nicht. Lösche die Datei
"config/config.txt", dann darfst Du nochmal von vorne anfangen,
denn dann werden alle Einstellungen auf "Default" gesetzt.

Grüße

tbengel