MyMDb-CE 1.X.X (Fragen / Bugs / Wünsche)

Erstellt von tbengel, 24 Dezember 2018, 09:22:15

Vorheriges Thema - Nächstes Thema

0 Mitglieder und 3 Gäste schauen sich dieses Thema an.

Silber13

Zitat von: tbengel nach 21 Januar 2019, 10:00:36
@Silber13:
Zitat von: Silber13 nach 21 Januar 2019, 02:27:55
Hallo

erst mal vielen Dank das Ihr euch die Mühe gemacht habt dieses Programm zu retten, tolle Arbeit.

Ich hab wie beschrieben das Programm runter geladen und die exe in meine My-MDb Datei kopiert, das Programm startet auch aber meine Daten werden nicht geladen.

Hab ich etwas falsch gemacht oder übersehen?


Nochmal, Du hast die Datei MyMDb-CE.exe in den Programm-Ordner von "MyDMb" kopiert. In diesem Verzeichnis gibt es jetzt unter anderem 2 EXE-Dateien. Einmal "mymdb.exe" und "MyMDb-CE.exe" --> richtig?

In diesem Verzeichnis befindet sich auch ein Ordner der "data" heißt --> richtig?

Du hast die Datei "MyMDb-CE.exe" nun mit Adminrechten gestartet und es erscheint nur ein leeres Fenster ohne die importierten Daten?

Grüße

tbengel

@tbengel

Genau so habe ich es gemacht, ich werde heute Abend es nochmal versuchen aber im Moment klappt es nicht

tbengel

@Silber13:
Zitat von: Silber13 nach 21 Januar 2019, 10:43:40
Genau so habe ich es gemacht, ich werde heute Abend es nochmal versuchen aber im Moment klappt es nicht


Dann schau heute Abend in den "data-Ordner", dort müssen sich (unter anderem) folgende Dateien befinden:

mymdb.script
mymdb.properties

Wenn Du dort die Dateien:

mymdbCE.script
mymdbCE.properties

findest, diese löschen. WICHTIG nur mymdbCE.* löschen NICHT mymdb.*!!!!

Danach MyMDb-CE.exe (mit Adminrechten) neu starten und berichte was passiert ...

Grüße

tbengel

ALi

Das mit der Speicherdauer kann ich auch nicht analysieren. Ob ein frührer oder späterer Eintrag. Manchmal auch bei neuen Filmen. Da reicht ein Wort. Mein Rechner ist schon flott und 32 GB Arbeitsspeicher sollten auch reichen. Mal geht es eben schnell und mal dauerts.

Mit dem Fenster im Hauptmonitor. Beim Fenster für einen neuen Film anlegen, war das am Anfag auch so. Aber nachdem ich mehrfach die aktuelle Ansicht gespeichert hatte, hat sich dieses kleine Fenster den Standort gemerkt. Geht zwar beim ersten Mal auf dem Hauptmonitor auf, aber dann beleibt auf dem Zweiten, auch bei mehreren neuen Filmen. Nur das Bearbeitenfenster nicht. In der 3.6 geht das ohne Probleme.
Ich bin leider nur Anwender.

Gruß

Old.Obelix

21 Januar 2019, 11:32:32 #273 Letzte Bearbeitung: 21 Januar 2019, 11:34:28 von Old.Obelix
@silber13:

Schau doch mal bitte unter dem Menüpunkt Daten/Datenbank/öffnen,
ob bei der Auswahl deine Datenbank hinterlegt ist,
wenn ja diese auswählen und mit ok bestätigen.

LG
Old.Obelix

tbengel

@Old.Obelix:
ZitatSchau doch mal bitte unter dem Menüpunkt Daten/Datenbank/öffnen,
ob bei der Auswahl deine Datenbank hinterlegt ist,
wenn ja diese auswählen und mit ok bestätigen.


Verdammt @Old.Obelix, ja dass wird es sein, @silber13 hat eine neue Datenbank angelegt und die alte DB
schon längst vergessen, wo er nichts eingetragen war. Hatte das gleiche Problem mit @korv, der immer
nur einen Eintrag in der DB hatte, obwohl die DB importiert wurde.

@silber13:

Das wird es sein ...

Grüße

tbengel

tbengel

21 Januar 2019, 11:47:04 #275 Letzte Bearbeitung: 21 Januar 2019, 11:53:41 von tbengel
@ALi:
ZitatDas mit der Speicherdauer kann ich auch nicht analysieren. Ob ein frührer oder späterer Eintrag. Manchmal auch bei neuen Filmen. Da reicht ein Wort. Mein Rechner ist schon flott und 32 GB Arbeitsspeicher sollten auch reichen. Mal geht es eben schnell und mal dauerts.


Dann liegt es nicht an der Größe des Kommentars. Wie viele Einträge hast du denn, ...?

Probiere mal den Tipp von @Old.Obelix und schalte unter Einstellungen/Quickinfo Settings
das QuickInfo-Panel ab. Dies hat bei mir (große DB > 10.000) wahre Wunder bewirkt.

Grüße

tbengel

ALi

Daran liegt es nicht. Habe das Quickinfopanel mal abgestellt. Ich habe aktuelle 2.121 Einträge. Wenn ich mal fertig bin werden das über 5.000 sein. Habe grade bei Nr. 2.072 das Wort "Test" in den Kommentar geschrieben. 43 Sekunden fürs Speichern. Bei Nr. 2.096 waren das nur Millisekunden. Die Speicher-Nr. entspricht der Hinzufüge-Reihenfolge.

???

tbengel

@ALi:

Tritt das Problem unvorhersehbar auf, oder umso mehr Filme Du eingibst um so länger dauert es ...

Grüße

tbengel

ALi

Völlig willkürlich. Habe gestern mehrere Sachen eingegeben, da ging alles flott. Heute Vormittag waren wieder zwei (aber nicht unmittelbar hintereinander) dabei, bei denen hat es dann wieder ewig gedauert.

tbengel

@ALi:
Hast Du die Möglichkeit, Deine DB auf einem anderen PC zu testen?

ALi

Zitat von: tbengel nach 21 Januar 2019, 14:12:43
@ALi:
Hast Du die Möglichkeit, Deine DB auf einem anderen PC zu testen?



Hab MyMDb jetzt auf meinem High-End-Gamer kopiert und ein BackUp des letzten Standes eingespielt. Habe der Genauigkeit halber die gleichen Einträge verwendet und "Test" wieder entfernt. Nr. 2.072 = 1 Minute 25 Sekunden, Nr. 2.096 = schwups. Der Rechner hat mindestens die 6fache Power meines Bürorechners.

tbengel

@Ali:
Zitat von: ALi nach 21 Januar 2019, 14:43:24
Zitat von: tbengel nach 21 Januar 2019, 14:12:43
@ALi:
Hast Du die Möglichkeit, Deine DB auf einem anderen PC zu testen?



Hab MyMDb jetzt auf meinem High-End-Gamer kopiert und ein BackUp des letzten Standes eingespielt. Habe der Genauigkeit halber die gleichen Einträge verwendet und "Test" wieder entfernt. Nr. 2.072 = 1 Minute 25 Sekunden, Nr. 2.096 = schwups. Der Rechner hat mindestens die 6fache Power meines Bürorechners.


Ich habe Dir per PM mal eine inoffizielle Testversion geschickt, mit der Du alle Deine Kommentare
auf einen Schwung löschen kannst. Nimm nur eine Test-DB dazu, denn die Kommentare sind danach
wirklich weg.

Ich will mal sehen, ob es tatsächlich an Deinen langen Kommentaren liegt. Die Computergeschwindigkeit
schließe ich aus ...

Grüße

tbengel

ALi


Ich habe Dir per PM mal eine inoffizielle Testversion geschickt, mit der Du alle Deine Kommentare
auf einen Schwung löschen kannst. Nimm nur eine Test-DB dazu, denn die Kommentare sind danach
wirklich weg.

Ich will mal sehen, ob es tatsächlich an Deinen langen Kommentaren liegt. Die Computergeschwindigkeit
schließe ich aus ...

Grüße

tbengel

PM??? Stehe auf dem Schlauch.  :unknown: :00000109:
[/quote]

Old.Obelix

21 Januar 2019, 16:16:55 #283 Letzte Bearbeitung: 21 Januar 2019, 16:21:02 von Old.Obelix
@Ali

Wenn es die Testversion ist, die wir Tester alle haben,
dann gehe im Menü auf Extras/Stapelverarbeitung,
da kommt das Fenster was du brauchst um deine Kommentare zu löschen.

LG
Old.Obelix

tbengel

ZitatPM??? Stehe auf dem Schlauch


Private Message --> Findest du unter "Meine Mitteilungen" hier im Board ...

Andre R.

Soooo... von mir ein kleines Update:

Letzte Mdb Version geladen, alle Testordner gelöscht, die neue CE Version ins Stammverzeichnis, geöffnet - läuft!

Zu atze's Anfrage: natürlich bleibe ich trotzdem verfügbar!


Viele Grüße

tbengel

@Andre R.:
Startest Du das Programm jetzt direkt über die JAR auf dem MAC?

Nova

@tbengel

Danke für die Antwort.
Leider ist der Lösungsansatz unter Windows 7 nicht möglich, oder :unknown:
Windows 10 verwende ich kaum, da klappt s vielleicht hab aber das aktuelle update noch nicht drauf.

Die EAN Suche ist hilfreich, wenn man nach Filmen sucht, deren Titel mehrfach auftaucht (z.B. King Kong, Robin Hood,...)
Hab es aus diesem Grund verwendet und die Laufzeiten bei DVDs und Blu-rays (+4%) stimmen meistens auch.

Habs nicht so eilig verwende die 3.6 er noch parallel  :banana:



ALi

Zitat von: ALi nach 21 Januar 2019, 16:13:05

Ich habe Dir per PM mal eine inoffizielle Testversion geschickt, mit der Du alle Deine Kommentare
auf einen Schwung löschen kannst. Nimm nur eine Test-DB dazu, denn die Kommentare sind danach
wirklich weg.

Ich will mal sehen, ob es tatsächlich an Deinen langen Kommentaren liegt. Die Computergeschwindigkeit
schließe ich aus ...

Grüße

tbengel

PM??? Stehe auf dem Schlauch.  :unknown: :00000109:

[/quote]

So, hab' das alles gemacht. Alle Kommentare weg. Dann habe ich den Eintrag Nr. 2.072 verwendet und in das leere Kommentarfeld ,,Test" geschrieben. 1 Minute 25 Sekunden fürs Speichern.
Eintrag wieder geöffnet und ,,Test" wieder gelöscht = schwupps. Nochmal eingetragen = schwupps.
Also scheint irgendetwas aus der alten Datenbank die neue zu blockieren. Die neue Version braucht zumindest einmal ein Speichern, damit sie sich ,,säubert".

Immer noch ???

birkner

@all.
Von Old.Obelix wurde ich gefragt, wie man selbst Änderungen an den Medientypen vornehmen kann. Da dies für mehrere interessant sein könnte, will ich meine Vorgehensweise erläutern. Es funktioniert mit der jar-Version des Programms und wurde bei mir unter Linuxmint 19.1 Cinnamon (OpenJDK 10.0.2) durchgeführt.

Die neueste MyMDb-CE.jar-Datei wird entpackt:

Ergebnis:
MyMDb-CE/com
MyMDb-CE/i18n
MyMDb-CE/images
MyMDb-CE/javax
MyMDb-CE/META-INF
MyMDb-CE/mymdbce
MyMDb-CE/org
MyMDb-CE/font_metrics.properties
MyMDb-CE/hsqlServlet.class
MyMDb-CE/log4j.xml

Im Unterverzeichnis META-INF liegt die Datei MANIFEST.MF
Unter Linuxmint 19.1 habe ich sie folgendermaßen angepasst und abgespeichert:

Manifest-Version: 1.0
Sealed: true
Class-Path: .
Main-Class: mymdbce/GUIMain

Wichtig! Am Ende der Manifestdatei muss eine Leerzeile sein und den Punkt nicht beim Class-Path vergessen!

Im Unterverzeichnis images/typen liegen alle Bilder der Medientypen. Hier kann man nicht einfach neue ergänzen, da die Namen der Bilder durch die compilierte Version festgelegt sind. Man kann aber Bilder ersetzen und eigene Bilder auf Namen setzen, die man nicht benötigt.

Wenn das erledigt ist, wird alles wieder bis auf das images-Verzeichnis als ausführbare jar-Datei gepackt.

Dazu wird im Verzeichnis des vorher entpackten Programms folgender Befehl ausgeführt:

jar cvfm MyMDb-CE.jar META-INF/MANIFEST.MF mymdbce/*class javax/* mymdbce/search/* com/* i18n/* META-INF/* org/* font_metrics.properties hsqlServlet.class log4j.xml

Es entsteht eine neue jar-Datei MyMDb-CE.jar, für die unter Linux die Rechte auf ausführbar gesetzt werden müssen.
Dann können alle gepackten Dateien und Verzeichnisse gelöschte werden:

Ergebnis:
MyMDb-CE/images
MyMDb-CE.jar

Diese Datei kann nun gestartet und das Progarmm eingerichtet werden.
Änderungen an den Medientypen können auch später im ausgelagerten Verzeichnis vorgenommen werden.

Die MyMDb-CE.jar kann auch unter Windows verwendet werden.
Eine exe-Datei könnte z.B. mit mit dem freien Programm

launch4j-3.12-win32.exe

erstellt werden. (Hierbei kann ich aber leider nicht helfen)

VG birkner

tbengel

Zitat von: ALi nach 21 Januar 2019, 18:45:31
So, hab' das alles gemacht. Alle Kommentare weg. Dann habe ich den Eintrag Nr. 2.072 verwendet und in das leere Kommentarfeld ,,Test" geschrieben. 1 Minute 25 Sekunden fürs Speichern.
Eintrag wieder geöffnet und ,,Test" wieder gelöscht = schwupps. Nochmal eingetragen = schwupps.
Also scheint irgendetwas aus der alten Datenbank die neue zu blockieren. Die neue Version braucht zumindest einmal ein Speichern, damit sie sich ,,säubert".

Immer noch ???


Ich habe Dir eine PM zu diesem Problem geschickt. Schau in Deine Nachrichten :icon_razz:

Grüße

tbengel

Andre R.

Zitat von: tbengel nach 21 Januar 2019, 17:54:42
...direkt über die JAR auf dem MAC?

Nein, läuft auf Windows10 über die virtuelle Maschine (VMware).
Die .jar lässt sich zwar auf dem Mac starten, aber ich habe es noch nicht geschafft meine Daten einzubinden.

tbengel

Zitat von: Andre R. nach 22 Januar 2019, 00:01:48
Zitat von: tbengel nach 21 Januar 2019, 17:54:42
...direkt über die JAR auf dem MAC?

Nein, läuft auf Windows10 über die virtuelle Maschine (VMware).
Die .jar lässt sich zwar auf dem Mac starten, aber ich habe es noch nicht geschafft meine Daten einzubinden.

Du brauchst nur den "data"-Programmordner aus dem MyMDb-Verzeichnis aus Deiner VM. Diesen auf den Mac in das Verzeichnis
wo die MyMDb-CE.exe liegt rüberkopieren ... So jedenfalls die Theorie  :D

perlian

So nun werd ich auch mal wieder meinen Senf dazutun

Ich weiß ja nicht ob schon mal jemand das Ergebnis des HTML Exports begutachtet hat
Ich habe nämlich seit Jahren meinen Filmbestand auf einem privaten Webserver.

Also ich fand das die Ausgabe in der ursprünglichen MyMDb Version besser aussah.

Kann das jemand bestätigen ?

Es war einfach pro Bildschirmseite mehr zu sehen.
Jetzt nimmt der Plot jedes einzelnen Films viel zuviel Platz ein

Sicher hat das keine Priorität aber auch dem Thema sollte man beizeiten Aufmerksamkeit schenken

Ebenso war der PDF Export ne feine Sache

Ansonsten tippitoppi :dodo:

Silber13

@Old.Obelix

Ja genau das war mein Fehler, hab nicht daran gedacht das noch eine leere alte Datenbank besteht


@tbengel

Danke auch für Deine Hilfe

Old.Obelix

22 Januar 2019, 07:12:16 #295 Letzte Bearbeitung: 22 Januar 2019, 07:17:35 von Old.Obelix
@Ali

Zitat


So, hab' das alles gemacht. Alle Kommentare weg. Dann habe ich den Eintrag Nr. 2.072 verwendet und in das leere Kommentarfeld ,,Test" geschrieben. 1 Minute 25 Sekunden fürs Speichern.
Eintrag wieder geöffnet und ,,Test" wieder gelöscht = schwupps. Nochmal eingetragen = schwupps.
Also scheint irgendetwas aus der alten Datenbank die neue zu blockieren. Die neue Version braucht zumindest einmal ein Speichern, damit sie sich ,,säubert".

Immer noch ???


Hallo Ali,

wenn Du immer noch das gleiche Problem hast, beginne noch einmal von ganz vorne.

1.   MyMdb-CE downloaden und entpaken
2.   Die MyMDB-CE.exe in das Verzeichnis von MyMDb 3.6 kopieren
3.   Falls noch vorhanden, in Data/ mymdbce.properties und mymdbce.script löschen
4.   MyMDb-CE umstellen auf Start mit Administrator-Rechten

Klicke dazu auf MyMDb-CE.exe mit der rechten Maustaste, Fenster öffnet, wähle Eigenschaften aus, gehe auf den Reiter Kompatibilität,  Hacken reine bei Programm im kompatibilitäts Modus ausführen, bei Windows 10, Windows 8 einstellen, Hacken rein bei Programm als Administrator ausführen und mit OK bestätigen.

5.   MyMDb-CE starten
6.   In Bearbeite/Einstellungen/ Header ausschalten
7.   In Quickinfo Settings/ QuickInfo-Panel komplett ausschalten
8.   Die übernommene Datenbank sichern
9.   MyMDb-CE beenden
10.   Neu starten
11.   Testen

Wenn das Problem immer noch besteht, Datenbank löschen

12.   MyMDb-CE beenden
13.   Neu Starten
14.   WICHTIG!!! Nun die neu gesicherte Datenbank unter MyMDb-CE wieder einspielen Header und Quick-Info Panel sollten aus sein
15.   Testen
16.   Jetzt sollte dein Problem weg sein!

Wenn Du MyMDb 3.6 parallel nutzt, achte bitte darauf, dass Du immer unter Extras/Konvertiere DB für MyMDb nutzt und kein Backup von MyMDb-CE einspielst, denn das könnte eventuell der Auslöser zu dem von dir beschriebenen Problem gewesen sein.

LG
Old.Obelix

ALi

Hallo Old.Obelix!

Wenn ich das mache, sind aber meine Einträge seit Umstellung auf die neue Version futsch. Ich habe die 3.6 noch auf dem Rechner und habe immer mal verglichen. Aber eingetragen habe ich gleich nach erfolgreicher Datenübernahme in die neue Version.

Gruß

tbengel

@ALi:
Probiere im ersten Schritt, das von meiner Mail aus ...

Falls es nicht klappt, mache die Sachen von Old.Obelix (in einer Test-Datenbank) und teste,
ob die Probleme wieder auftauchen oder nicht. Wenn das Problem dadurch gelöst wäre,
können wir händisch die neuen Daten auf Deine Test-Datenbank schieben, dies wäre das
kleinste Problem ...  ;)

Grüße

tbengel

ALi

Problem gelöst. Danke an alle Tippgeber!!!!! :banana:

Old.Obelix

22 Januar 2019, 14:41:02 #299 Letzte Bearbeitung: 22 Januar 2019, 14:50:18 von Old.Obelix
@tbengel
@Ali

Zitat
Problem gelöst. Danke an alle Tippgeber!!!!! :banana:


So funktioniert Community!!!

Man versteht sich eigentlich Blind, :dodo:

man hält zusammen, :respekt: :respekt: :respekt:
sucht gemeinsam nach Lösungen :thinking:
und freut sich über das TOLLE ERGEBNIS :party:

Das mach richtig Spaß!!! :D

Und jetzt ein Käffchen. :andy:

LG
Old.Obelix