MyMDb-CE 1.X.X (Fragen / Bugs / Wünsche)

Erstellt von tbengel, 24 Dezember 2018, 09:22:15

Vorheriges Thema - Nächstes Thema

0 Mitglieder und 1 Gast schauen sich dieses Thema an.

franklyn

Hi tbengel,

Zitat von: tbengel nach  6 November 2020, 18:40:59Ich schätze mal, Du hast was in der Config kaputtgebastelt.
... ich hab da nix angefasst...


Zitat von: tbengel nach  6 November 2020, 18:40:59Lösche die Datei "config/config.txt", dann darfst Du nochmal von vorne anfangen,
Mach ich mal... danach geb ich Rückmeldung....



Greetz, franklyn

franklyn

Nabend tbengel,

Habe fertig...

War ja gar nicht so schlimm, sind ja nur die Einstellungen in die "default" zurückgesetzt worden, mehr nicht..
(habe vorher also doch was "angefasst")
Protokolliere jetzt jeden Schritt:.

- Habe nun nur in "Filmdatenupdates/OFDb-Datenfelder" alles abgehakt, außer die "OFDb´s"
- in "OFDb-EAN Datenfelder" alles abgehakt
- in "Parser Settings/Daten durch Sekundärquelle ersetzen" alles abgehakt

- übernehmen und Programm-Neustart

- Film hinzufügen
https://ssl.ofdb.de/film/2806,Der-Wilde-Planet
https://ssl.ofdb.de/film/5472,Die-Reise-zum-Mittelpunkt-der-Erde

Ergebnis: beide Filme werden hinzugefügt, aber ohne Cover (bzw. "No-Cover-Cover") erscheinen in Hauptansicht


- in "Parser Settings/Daten durch Sekundärquelle ersetzen" nun Cover angehakt
- übernehmen und Programm-Neustart

- erneut (letzten) Film hinzugefügt:
https://ssl.ofdb.de/film/5472,Die-Reise-zum-Mittelpunkt-der-Erde

- Abfrage "trotzdem hinzufügen": JA
Ergebnis: Film wird hinzugefügt, diesmal mit Cover, ABER anderes Cover als auf OFDb sichtbar


Zur Kontrolle mal auf IMDb nachgeschaut...
https://www.imdb.com/title/tt0052948/
Dort ist das soeben eingetragene Cover zu sehen...




SO sieht das hier leider aus.... Any Idea ??? :denk: :denk: :denk: :denk: :denk:

Greetz, franklyn

tbengel

Hall franklyn,

ich weiß nicht, was Du da die ganze Zeit abhakts und anhakst ...

Lass es doch einfach so, wie es in den Default-Einstellungen vorgegeben
ist, dann klappt es auch mit dem Cover.

Grüße

Thomas

Old.Obelix

Zitat von: franklyn nach  7 November 2020, 03:52:45Nabend tbengel,

Habe fertig...

War ja gar nicht so schlimm, sind ja nur die Einstellungen in die "default" zurückgesetzt worden, mehr nicht..
(habe vorher also doch was "angefasst")
Protokolliere jetzt jeden Schritt:.

- Habe nun nur in "Filmdatenupdates/OFDb-Datenfelder" alles abgehakt, außer die "OFDb´s"
- in "OFDb-EAN Datenfelder" alles abgehakt
- in "Parser Settings/Daten durch Sekundärquelle ersetzen" alles abgehakt

- übernehmen und Programm-Neustart

- Film hinzufügen
https://ssl.ofdb.de/film/2806,Der-Wilde-Planet
https://ssl.ofdb.de/film/5472,Die-Reise-zum-Mittelpunkt-der-Erde

Ergebnis: beide Filme werden hinzugefügt, aber ohne Cover (bzw. "No-Cover-Cover") erscheinen in Hauptansicht


- in "Parser Settings/Daten durch Sekundärquelle ersetzen" nun Cover angehakt
- übernehmen und Programm-Neustart

- erneut (letzten) Film hinzugefügt:
https://ssl.ofdb.de/film/5472,Die-Reise-zum-Mittelpunkt-der-Erde

- Abfrage "trotzdem hinzufügen": JA
Ergebnis: Film wird hinzugefügt, diesmal mit Cover, ABER anderes Cover als auf OFDb sichtbar


Zur Kontrolle mal auf IMDb nachgeschaut...
https://www.imdb.com/title/tt0052948/
Dort ist das soeben eingetragene Cover zu sehen...




SO sieht das hier leider aus.... Any Idea ??? :denk: :denk: :denk: :denk: :denk:

Greetz, franklyn
Hallo Franklyn,

ich weis nicht was Du machst!
Bei meinem Test funktioniert es alles einwandfrei.

Mache es genau nach den Nachfolgenden Schritten
und Du wirst sehen das es funktionier mit deinen Covern.

1.Einstellungen Filmupdates Siehe Screenshot

Image 002" border="0

2.Einstellungen Parser Settings Siehe Screenshot

Image 003" border="0

3.Ergebnis Covers

Cover wählen" border="0

Wie Du an den Erstellungsdaten siehst,
aktuell getestet und es funktioniert einwandfrei.

Dann noch eine Bitte, lies doch erst mal das Handbuch, denn da steht alles genau beschrieben.

Gruß
Old.Obelix

franklyn

7 November 2020, 11:59:44 #1234 Letzte Bearbeitung: 7 November 2020, 12:23:01 von franklyn
@tbengel,


Zitat von: tbengel nach  7 November 2020, 11:11:56ich weiß nicht, was Du da die ganze Zeit abhakts und anhakst ...
???  habe ich doch genau geschrieben.  :denk:


Zitat von: tbengel nach  7 November 2020, 11:11:56Lass es doch einfach so, wie es in den Default-Einstellungen vorgegeben
ist, dann klappt es auch mit dem Cover.

NEIN, eben nicht !
Dann sind da zwar Cover, aber (ich schrieb es...) die "falschen". :sad:




@Old.Obelix

Ich habe nocheinmal (... zur Vorsicht... damit es clean ist...) die Datei "config/config.txt" gelöscht und NIX geändert.

Unter 1. und 2. sieht bei mir alles genauso aus, wie in Deinen screenshots.

ABER: Unter 3. (Bearbeitungsfenster) habe ich nix zur Wahl !!!!

Dort sehe ich  entweder das "No-Cover-Cover"  ODER    einzig und alleine    das IMBd-Cover !! 
NIX OFDb !!

Was bei Dir da zu sehen ist (also eine Wahlmöglichkeit), hätte ich auch gerne...


Greetz, franklyn

p.s.
Handbuch hatte ich vorher bereits konsultiert...
(Ist ja auch nicht anders als jahrelang bei der 3.6 ...)
Abweichend vom Handbuch ist natürlich S.88, da ich den link direkt eingebe (s. oben...)
und die "Suche" gar nicht erst benutze.

tbengel

7 November 2020, 12:59:21 #1235 Letzte Bearbeitung: 7 November 2020, 13:01:24 von tbengel
Zitat von: undefined
Zitat von: tbengel nach  7 November 2020, 11:11:56Lass es doch einfach so, wie es in den Default-Einstellungen vorgegeben
ist, dann klappt es auch mit dem Cover.

NEIN, eben nicht !
Dann sind da zwar Cover, aber (ich schrieb es...) die "falschen". :sad:
Dann mache mal Bilder, welche Cover Du erhälst und welche
Du erwartest, wenn Du die Einstellungen nicht angefasst hast!

Du musst doch die gleichen Bilder erhalten, wie bei @Old.Obelix!

Grüße

tbengel

P.S. ... und die "data/config.txt" erst löschen, nachdem Du MyMDb-CE geschlossen hast!

franklyn

8 November 2020, 01:09:53 #1236 Letzte Bearbeitung: 8 November 2020, 15:55:49 von franklyn
Nabend tbengel und Old.Obelix,


ich komme mir mittlerweile vor wie in einer sich wiederholenden Wiederholungs-Schleife die sich wiederholt und wiederholt und....  :denk2:
Ich mag ja manchmal nicht alles kapieren, aber SO bescheuert bin ich (hoffentlich) ja nun auch nicht...
Zumal, wenn ich mich genau an die gegebenen Anweisungen halte...


Zitat von: tbengel nach  7 November 2020, 12:59:21Dann mache mal Bilder, welche Cover Du erhälst und welche
Du erwartest, wenn Du die Einstellungen nicht angefasst hast!
Ich brauch da nich extra neue Bilder machen, da:

Ich erhalte jeweils das zweite (rechte) Cover, die in den screenshots von Old.Obelix zu sehen sind.
Und zwar jeweils - N U R -  das zweite (rechte) Cover-Bildchen (das von IMDb...)
Deswegen habe ich geschrieben:
Zitat von: franklyn nach  7 November 2020, 11:59:44Dann sind da zwar Cover, aber (ich schrieb es...) die "falschen". :sad:

Ich erwarte aber das erste (linke) Cover-Bildchen (die von OFDb...)

Wenn ich die Wahl HÄTTE, wie in den screens von Old.Obelix zu sehen ist,
WÄRE das natürlich noch schöner.

Ich aber nie nix haben Wahl, ich immer und N U R kriegen IMDb-Cover.
(oder aber gar kein Cover, wenn bei "Sekundärquelle" keine Haken gesetzt sind / Cover "abgehakt" ist... )

Zitat von: tbengel nach  7 November 2020, 12:59:21Du musst doch die gleichen Bilder erhalten, wie bei @Old.Obelix!
Is aber nicht so !


Zitat von: tbengel nach  7 November 2020, 12:59:21P.S. ... und die "data/config.txt" erst löschen, nachdem Du MyMDb-CE geschlossen hast!
Genauso habe ich das gemacht.
Programm ist geschlossen, "config.txt" gelöscht, Programm gestartet, Film hinzufügen...


Und ja, "meine" Einstellungen sehe genauso aus, wie in den screenshots von Old.Obelix.
Ich dennoch nix kriegen Cover von OFDb.
Ich aber (meist) wollen die von OFDb.

WAS soll ich noch Neues sagen, was ich nicht bereits gesagt habe ????


Greetz, franklyn

tbengel

Hallo @franklyn,

schalte mal Deine Firewall ab, es kann sein, dass Du da irgendwelche
Einstellungen gemacht hast, die vielleicht Dein Problem verursachen,
oder teste es mal an einem anderen PC.

Ich habe von dem Problem, welches Du schilderst noch nie (innerhalb
der letzten zwei Jahre) gehört, also schätze ich mal es liegt an Deinen
PC-Einstellungen.

Warum solltest Du keine OFDb-Bilder bekommen, sondern nur die IMDb-Bilder.
Kommt mir schon sehr komisch vor, da ich es nicht reproduzieren kann.

Grüße

tbengel

franklyn

8 November 2020, 15:52:19 #1238 Letzte Bearbeitung: 8 November 2020, 15:56:15 von franklyn
Hallo tbengel,
mir ist jetzt, nach deinem neuen Hinweis, etwas aufgefallen, das wohlmöglich mit dem Problem zu tun haben könnte ?

Allerdings kenne ich mich mit den Tiefen des Programms und seinen Abhängigkeiten / online-Abläufen null aus,
ich habe das Programm ja nicht geschrieben und bin nur ein doofer User.
Daher kann ich auch im einzelnen nicht nachvollziehen, was das Programm genau wie macht / machen will, wenn es online ist.


Auf dem online-Rechner, mit dem auch früher immer mit MyMDb 3.6 die neuen Filme eingetragen wurde, fragt mich meine Firewall beim Start von 3.6,
ob das Programm "MyMDb" eine Verbindung ins Internet (Zieladresse: "www.my-movie-database.de") herstellen darf.

Das habe ich natürlich mit JA erlaubt und alles funzte.

Bei 3.6 gab es ja noch keine "Sekundärquelle", die Cover kamen immer von OFDb.
(Gab es -selten- dennoch mal keins oder wollte ich ein anderes haben, musste man das halt manuell erledigen.)
Soweit so gut.


Bei der 1.93 hingegen werde ich, wie ich gerade überprüft habe, nicht gefragt ob "MyMDd" eine Verbindung herstellen darf,
sondern ob "Jave(TM)Platform SE binary" eine Verbindung (zu "www.my-movie-database.de") herstellen darf .

Natürlich habe ich die Abfrage ebenfalls mit JA erlaubt (quasi genau wie vorher).
(Dieser "Unterschied" war mir bisher gar nicht weiter aufgefallen.)

Der Zielpfad auf dem Rechner (in der Firewall angezeigt) geht aber auch nicht mehr, wie zuvor,
zur "MyMDb.exe" in dem MyMDb-Ordner (bzw. "MyMDb-CE.exe" im MyMDb-CE-Ordner),
sondern geht bei der 1.93 zur "javaw.exe" im Programme/Java-Ordner.

Aber jetzt funzt es ja ganz offensichtlich nur "teilweise" und ich habe das beschriebene Verhalten, daß die Cover von OFDb gar nicht, sondern nur die von IMDb geladen werden...


Ich denke, das könnte ein wichtiger Hinweis bei dieser Problematik sein ?


Daher meine Vermutung.
So wie es sich gerade für mich darstellt, scheint das alles an der "inneren Programmstruktur" von der 1.93 bzw. im besonderen mit Java zu tun zu haben.
Liegt das ganze Ding vielleicht hauptsächlich an Java ?

Nun kenne ich mich mit Java null aus!
Habe mir die Einstellungen zwar mal angesehen, aber alles untouched gelassen, weil mir das alles zu spanisch vorkam und ich nix verhunzen wollte.
Aber "einstellen" kann man dort ja was....

Kann ich in den Java-Einstellungen etwas "ändern" oder "freigeben" ?
Wenn ja, WO und WIE genau?


Vielleicht kann sich das alles ja auch mal ein Java-Gott genauer ansehen,
der in den Tiefen des Codes diesbezüglich etwas zu entdecken vermag ?


Ich hoffe wirklich inständig , dass wir das hier hinkriegen...

Greetz, franklyn

p.s.
Firewall mal vorübergehend komplett abgeschaltet. - Keine Änderung.
An einem anderen PC kann ich nicht testen.

tbengel

Hallo franklyn,

es liegt entweder an einer Firewall-Einstellung, oder an Deiner Java-Version.
Ich kann Dir nur raten damit herumzuspielen und auf einem anderen PC zu
testen.

Ich kann nur Fehler fixen, die ich reproduzieren kann, aber Dein Verhalten
ist für mich nicht erklärbar und kam bisher auch noch nie vor.

Sorry

tbengel

franklyn

9 November 2020, 02:03:20 #1240 Letzte Bearbeitung: 9 November 2020, 02:06:53 von franklyn
Nabend tbengel,


Zitat von: tbengel nach  8 November 2020, 16:52:43es liegt entweder an einer Firewall-Einstellung
Zitat von: franklyn nach  8 November 2020, 15:52:19p.s.
Firewall mal vorübergehend komplett abgeschaltet. - Keine Änderung.

Zitat von: tbengel nach  8 November 2020, 16:52:43oder an Deiner Java-Version
Ich dachte man braucht Java ab Version 8
Welche 8.xxx muss man denn mindestesns haben?
Habe diesbezüglich hier (und Handbuch) keine genaueren Infos erhalten.

Zitat von: tbengel nach  8 November 2020, 16:52:43Ich kann Dir nur raten damit herumzuspielen
WAS soll ich denn spielen? Damit kann ich leider gar nix anfangen.
Ich schrieb doch schon:
Zitat von: franklyn nach  8 November 2020, 15:52:19Nun kenne ich mich mit Java null aus!
Oder womit und was soll ich spielen?

Zitat von: tbengel nach  8 November 2020, 16:52:43und auf einem anderen PC zu testen.
Zitat von: franklyn nach  8 November 2020, 15:52:19An einem anderen PC kann ich nicht testen.

Zitat von: tbengel nach  8 November 2020, 16:52:43aber Dein Verhalten ist für mich nicht erklärbar
Ja, das sagtest du bereits mehrfach. Aber was sagst du denn zu
Zitat von: franklyn nach  8 November 2020, 15:52:19Ich denke, das könnte ein wichtiger Hinweis bei dieser Problematik sein ?
Zitat von: franklyn nach  8 November 2020, 15:52:19So wie es sich gerade für mich darstellt, scheint das .....  im besonderen mit Java zu tun zu haben.


Zitat von: tbengel nach  8 November 2020, 16:52:43für mich nicht erklärbar und kam bisher auch noch nie vor
Irgendwann ist irgendetwas immer das erste mal...
Es muss doch (wenn nicht von Dir, von wem dann?) herauszufinden sein,
Zitat von: franklyn nach  8 November 2020, 15:52:19was das Programm genau wie macht / machen will, wenn es online ist.
An dieser Stelle dürfte dann doch (für den Programmierer, der sich das alles ausgedacht und programmiert hat) auch irgendwo die Lösung zu finden sein.
Soviel ich vom Internet bisher verstehe,
sind "https://ssl.ofdb.de"  und  "https://www.imdb.com" doch zumindest zwei unterschiedliche Adressen.

Im realen Leben muß ich mich doch auch nicht wundern, wenn ich in der "Wagenstraße 6" klingele,
um von der schönen Monika reingelassen zu werden,
mir stattdessen aber der der bärtige Jakob die Tür öffnet, weil ich eben nicht in Berlin auf der Wagenstraße bin, wo die Moni wohnt,
sondern in München auf der Wagenstraße vor der Tür stehe. Meine Frau sagt in so einem Fall immer: "Guuutes Navi, fein so."



Zitat von: franklyn nach  8 November 2020, 15:52:19Vielleicht kann sich das alles ja auch mal ein Java-Gott genauer ansehen,
der in den Tiefen des Codes diesbezüglich etwas zu entdecken vermag ?

Da Du ja hiermit überfragt bist, könntest Du nicht mal diese Problematik an Euren Codegott weiterreichen / hierauf hinweisen, Ihr kennt Euch doch, oder?

greetz, franklyn

tbengel

9 November 2020, 09:29:21 #1241 Letzte Bearbeitung: 9 November 2020, 09:39:31 von tbengel
Hallo franklyn,

ZitatDa Du ja hiermit überfragt bist, könntest Du nicht mal diese Problematik an Euren Codegott weiterreichen / hierauf hinweisen, Ihr kennt Euch doch, oder?
Das Forum ist frei, jeder kann hier mitmachen und seine Ideen einbringen. Es gab immer
mal wieder Probleme mit Java-Versionen, deshalb kontrolliere mal unter Einstellungen /
"App und Features" Deine Java-Version. Da sollte: "Java 8 Update 271 (64-bit)" stehen
(bei einem 64 bit Betriebssystem).

Ich könnte mir noch vorstellen, dass der Zugriff zur OFDb über MyMDb-CE irgendwie
unterbunden wird, aber wenn Du sagst, dass Du die Firewall deaktiviert hast und auch
die windows-eigene Firewall nicht zuschlägt, kann es auch das nicht sein.

Wie gesagt, ich kann Dein Problem nicht reproduzieren. Es liegt einzig und
allein an der Konfiguration Deines Systems und nicht am Programm. Von daher
bin ich nun bezüglich Deines Problems raus ...

Wir rufen nun den Codegott von MyMDb-CE ... möge er uns helfen  :happy3: ...

Grüße

tbengel

ingi

Folgende Konstellation:
2 Rechner im Haushalt greifen auf eine gemeinsame Datenbank (via NAS) zu.
Momentan hat jeder Rechner sein eigenes Outfit (Spaltenanordnung, -größe, Schriftgröße, Farben usw,). Die Configordner liegen (noch)... auf dem jeweiligen Rechner selbst.
Ein Rechner arbeitet mit einem 24-Zoll-Monitor, der Laptop hat nur 15 Zoll.
Die Ansicht auf dem 15-Zoll-Laptop ist nahezu unverändert belassen.
Kann ich jetzt den Configordner des "großen" Monitors auch via NAS für den kleinen Monitor zugänglich machen?
Ändern sich die Größenverhältnisse 1:1 im gleichen Verhältnis, oder kann es dann passieren, dass z.B. Coverbilder nicht mehr in die Spalten passen oder es Probleme mit der Schriftgröße für die Spalten gibt.
Ideal wäre es, wenn die Ansicht komplett übernommen wird, bloß halt im Gesamten auf 15 Zoll verkleinert... .  :denk:

tbengel

Hallo @ingi,

es ist keine Frage der Größe des Monitors, sondern die Auflösung,
welche angezeigt wird, jedoch nehme ich an, dass die Auflösung
auf Deinen beiden Rechnern auch unterschiedlich sein wird.

In der Config-Datei ist für jede Spalte die Spaltenbreite festgelegt,
wobei die grafischen Spalten (also z.B. "Cover") in der Breite fixiert
sind. Was nicht passt, wird verkleinert oder Du stellst in den Einstellungen
die Tabellen-Ansicht auf "Tabellenbreite mit Scrollbalken".

Teste es doch einfach mal aus. Sichere Deinen Config-Ordner auf dem
Laptop und kopiere den Config-Ordner vom Rechner rüber. Dann das Programm
auf dem Laptop starten und schauen was passiert.

Zur Not hast Du ja die Sicherung  :happy3: ...

Grüße

tbengel

ingi

Gut, vielen Dank, dann mach' ich das mal so...!  :respect:

Gruß,  ingi